My Wifi not working

Hi, I have installed the new update.
However, I am facing wifi issue. There is no wifi connection shown on the network icon. It seems the wifi driver is removed/ not installed after updating.

Please help to fix this issue.

Hello , I could help more if you give more details about your regular internet connection ( Is it wireless or wired ? ) Or when you say about the new update…which one, manjaro stable latest one or other? We also have telegram channel where I am connected right now ( with this link you can access to it Telegram: Contact @maboxlinux ) or leave more details here with some details from terminal for example what results you get when you type : inxi -n

The issue is the wireless connection (Wifi). At the moment, once I power on this laptop, the wifi network is available and shows the wifi connection. Previously, when I restart my laptop, it still not showing any wireless connection.

This issues frequently happening for the past few months. Most of time, I use Lan cable hence I did not bother with this issue. However, since I am at new place which requires WIFI, then i would like to solve it since it always happening.

Yesterday, I have new update but i think it is only for software.

I would like to know what to do if this still continue to happens.

Thanks in advance.

Can you add a small picture showing the results from your terminal when you type :inxi -n (and press enter key) ? This is my terminal with my local results :

Hi this is the result from my terminal. Currently, I am using USB tethering. The wifi driver can be detected, however it keeps shows wifi was diasable even though I already enable the wifi.

I recommend to keep using your terminal and check where the error can be in the journal list; for this you have to use this command : journalctl -xb
(example of results ) https://i.imgur.com/nsP8bqZ.png

press enter and look carefully a line with references to your wireless card Qualcomm Atheros AR9485 athk9 including the word error… so you can check in the previous link(https://wiki.archlinux.org/title/Network_configuration/Wireless#Cause_#5) if you can solve your problem by using the recommended processes for this impasse.
I hope this can help you.

Thank you for your assistance.

I am looking on this matter. Still checking what the error is.
Hope it can be fixed. Will update later.

Hello,

I have tried your suggestion. However, I could not see any error that matches from the link.
Currently, I have installed new update which is software and linux kernels and suddenly after restart, there is no wifi driver installed shown in the terminal.

Mabox_2022-06-17-11-16-1655435792

This issues keeps happening. I am wondering what the best way to solve this issue.

1 Like

I found in the manjaro forum a recent issue with your wireless card dropping connections, as you mentioned you moved a different place it can be similar, and this user could solve it referring to the modem’s regulatory domain changes… I hope this could help u more I leave both 2 links so you check if it solves your dropping connections:

https://wiki.archlinux.org/title/Network_configuration/Wireless#Respecting_the_regulatory_domain

Yeah. Just updated from Herbo…same shit. Timeshifted back to see whattup.
BTW…That’s why my main systems are all Debian(s) and not Farch. Damn oldies and goodies. Gotta go get some beer in my 76 Land Cruncher diesel and then have a look

1 Like