Using the keyboard widget w/ the XFCE Panel

I use the XFCE Panel with MaBox with the keyboard widget to toggle between American English and Latin American settings;

But the widget doesn’t work with MaBox.

What setting do I have to change to accomplish that?

Thanks in advance for your response.

No idea about XFCE panel and its widgets, but you can install fbxkb to have systray applet that should work with any panel (tested with tint2).

yay fbxkb

Add 2 lines to autostart script:

setxkbmap -option grp:switch,grp:shifts_toggle,grp_led:scroll pl,us &
fbxkb &

Here pl,us means polish and american, replace with your choice.

Then you have indicator/switcher autostarted in system tray.
You can also switch by pressing both Shift keys together.

That should do it.

(I’ll give it a try).

I made the change in the openbox autostart file with lat instead of pl

Then I rebooted but don’t see where I can toggle from and hitting both shift keys at once doesn’t result in a change either.

What am I missing?

Did you try to run those two commands from terminal?

Since pamac was open I used it to install fbxkb, along with it’s dependency,

And added the line to the openbox autostart file.

After rebooting, I see no way to toggle over.

(Running fbxkb in a terminal I get:

Blockquote
(fbxkb:4203): Gtk-WARNING **: 10:56:14.535: Unable to locate theme engine in module_path: “clearlooks”,

(fbxkb:4203): Gtk-WARNING **: 10:56:14.536: Unable to locate theme engine in module_path: “clearlooks”,
xkb group #0 is already defined

Blockquote

The XFCE-4 panel widget shows two settings on right clicking:

Keyboard settings and

Keyboard Layouts but the latter is grayed out for some reason.

(With Manjaro Openbox this is not the case, but I consider Mabox to be a significantly more polished OS and would like to get this detail fixed).

You have changed the tint2 panel - supplied by Mabox to the XFCE panel and you have a problem with the XFCE keyboard layout widget not working.

I gave you an alternative solution using fbxkb, fully tested in Mabox and working fine with the tint2 panel provided by Mabox.

Sorry to hear this doesn’t work with the XFCE panel.

Anyway, it doesn’t seem like a problem with Mabox :slight_smile:

I have the tint2 panel above and the xfce panel below

I don’t see where fbxkb (which IS installed) is visible in the tint2 panel.

Apparently, you’re not going to respond to that.

What I need to know is, in which files are the keyboard settings located.

Obviously, mabox handles that different than manjaro does (since this problem does not occur in the manjaro edition of pacbang - which is no longer listed in the community versions available for Manjaro).

Are you the major mabox developer?

Thanks in advance for your response.

Mabox is based on Manjaro and it handles that the same.

You can change keyboard layout from cli with command (for example):

setxkbmap us

See man setxkbmap if you want to know more.

I checked solution proposed by me with first answer (with fbxkb) and it works perfectly fine.
I even installed xfce4-panel and it also works perfectly fine with it.
I have no idea why it does not work for you, and quiet frankly I won’t spend any more time on this.

Maybe also worth to read: Xorg/Keyboard configuration - ArchWiki