Tint2 panel vanishes

Tint2 Panel Keeps Vanishing

Logitech K400+ issue


  • HP T730
  • 16GB Ram
  • 1TB SSD
  • Branch Stable
  • Kernel 6.1.23-1-Manjaro
  • 23.03 lstredd
  • Logitech keyboard K400+


Regardless of which tint2 panel I choose, the panel keeps getting
unchecked in the configuration app.
This started happening after updating the system at the end of March, 2023.


After doing some research I typed in the terminal:
tint2 -c ~/.config/tint2/mabox2001.tint2rc

Which return several lines, however, this error kept repeating:
tint2:found power device hidpp_battery_0
read failed for /sys/class/power_supply/hidpp_battery_0/present
tint2:failed to initialize battery"hidpp_battery_0'

This error continued repeating til:
segmentation fault(core dumped)
At which time the panel disappears.

/usr/src/ is an empthy directory.
/sys/…/present file doesn’t exist.

Using the keyboard reduces the times the error repeats before the
core is dumped.

I tracked this to the usb dongle of the Logitech K400+ keyboard
and trackpad I am using.

I have no issues with connecting to the keyboard/trackpad combo.

I’ve used the keyboard on other machines both windows and linux
(not Mabox or tint2) without issue. This unit worked flawlessly til
the end of March after that large update.

The dongle has the latest software.

I installed solaar and using solaar show outputs several
paragraphs of information which included the battery’s condition.
Changing batteries didn’t resolve the issue. Batteries are at 90%.
Turning off keyboard and/or removing the batteries didn’t alter
the problem. Only removing the dongle fixes the problem.

I install other Logitech dongles for other keyboard and/or mice
and they worked flawlessly. However, none of those dongles supply
the amount of information the K400+ dongle does when using solaar.

Any help in resolving this issue would be greatly appreciated.

Hello @grg1202 and welcome to the forum,

I would try to remove the battery indicator from the tint2 configuration…

grep panel_items  ~/.config/tint2/mabox2001.tint2rc
panel_items = PPLTSBCPP

Remove letter B then try to start tint2.

1 Like

Thanks for the reply. Unfortunately, It didn’t work. It does, however, take longer to fail.

Any other ideas?

Hello napcok,
On top of removing the B in panel_items I removed the %p from the bat1_format in the Battery section and just left it blank. This took care of the error. This isn’t a laptop so I don’t need a battery indicator.

Thanks for the help…


same happened to me. But since is a notebook, i would like to have the battery indicator and tint2 working. Any suggestion?

I found my dusty laptop, updated it and the tint2 battery indicator is working fine for me… Maybe it’s a hardware specific (?)

Just remove built-in tint2 battery indicator from config. Install cbatticon and use it instead.

1 Like