Tint2 panel started disappearing after system upgrade

After reloading theme in Mabox Theme Manager tint2 appears again. However, it is still unstable especially after watching on mpv and YT (full screen). “mabox-linux-23.01-Istredd-230126-linux515.iso” works fine. Please help or advice. Thx.

1 Like

Hello @liders and welcome to the forum :slight_smile:
I noticed tint2 crash right after updating Mabox in VirtualBox. On My PC everything works fine.
But seems this is a serious bug… :frowning:
How often it occur for you?

I will try to investigate this more…

Some references I’ve found so far:
freeze code (f3aa2ef0) · Commits · o9000 / tint2 · GitLab
[SOLVED] Tint2 crashing on startup / Applications & Desktop Environments / Arch Linux Forums
31869 – Something has broken tint2, probably recent glib2.0 update
A change in glib2 is crashing Openbox, xfce4-session, and other programs | Patches Promptly


Thx @napcok. I noticed that tint2 also disappears every time I put the system into suspend mode.

I just checked Mabox on the VM and there the problem with tint2 does not occur even after the upgrade

This is not a solution to problem, but i added option to make life a bit easier.

If tint2 crash again, it can be started from middle-click on desktop menu.


The patched version of tint2 has been uploaded to the Mabox repo.
Please check if this patch helps.

1 Like

Thank you for your support. I really appreciate it. Everything now works as it should. Masterwork :clap:

1 Like

I also got the Tint2 panel closing/disappearing out of the blue a few minutes ago.
After that upgraded right away to the latest (17.0.2-5) version; will keep an eye.

1 Like

Please notify me if patched tint2 package (17.0.2-5) still crashes.
For me, it works fine on my PC, Laptop and all VMs.

Hello, can you please provide a link to the actual patch that was applied to tint2 to work with >=glib-2.76? Thank you.

Hi @nathanzachary and welcome.

The good ole:

sudo pacman -Syu

Is enough to provide the patched version.

Thank you for your reply. I’m asking for the actual patch itself so that we can consider applying it in Gentoo. I haven’t been able to locate the mentioned patch.
Thanks again.

Hi, we need the patch to use with another Linux. Thanks.

Edit: Whoops. Nathan was faster.

BTW, I attempted to run the binary, missing dependency … I hope there is this patch available. :slight_smile:

Welcome again guys.

Let’s wait a little bit for the Boss. :sunglasses:

Hello @nathanzachary @Userblues :slight_smile:
I use this patch from Arch forum.

I still use tint 17.0.2 from o9000 / tint2 · GitLab
As 17.1.3 - fork from Nikita Zlobin / tint2 · GitLab seems very buggy.

Thank you @napcok for confirming. I found that patch yesterday and thought that it was probably the one applied here, but I appreciate you taking the time to validate my assumption.

1 Like

Wonderful! I tried good many replacements but none is as good as tint2. There is 17.0.2 in Gentoo portage, will get my hands on it now.

1 Like

Yes, tint2 is in a different league. Even with some of its problems.
It’s sad that there isn’t anyone who takes care of it right now.