The M-menu

Hi friends!

I am new on this forum, but i have enjoyed Mabox in one and a half year on a 7-8 years old Lenovo without any major problems. However after some updates, when i right click on the desktop, the M-menu does not appear from the mouse pointer, but from the M at the left upper corner from where the main menu is only attended to drop down if you click the M, or press the super key. This is not a problem but a cosmetic issue cause I REALLY loved having the the main menu coming from the mouse pointer! It seems to be the case on every themes. Anything I can do to get this back?

/Ingvar from Sweden


Hi @Ingvar
This issue is interesting. I remember I face it some time ago in Bunsenlabs (which I usually check every year or two - when there is new release). I never experienced this issue in Mabox.

I wonder what might be causing this behavior…

Any chance you have “plain” jgmenu in autostart?

Or maybe you by accident messed something with jgmenu config in ~/.config/jgmenu/ ?

Trying to reproduce this but no luck so far…

Can you check how other jgmenu based tools behaves?
For example:
super + s is “settings menu” - it should start at pointer.
super + x is “logout dialog” - it should start centered when invoked by shortcut
What about sidepanels and desktop menu (middle click on desktop)?

You may try to fix this by removing config files from ~/.config/jgmenu/

rm ~/.config/jgmenu/*

Hi @napcok!
Thank yo for the interesting answer. For some years ago I tested Bunsenlabs from a live stick and I found Openbox very cool. However I failed to install the OS. But when when I saw Manjaro been available with Openbox! that was something for my slow Lenovo.

In fact I haven’t changed anything in autostart, (where can I find it!) and I haven messed anything with the jgmenu. As you see my knowledge of Linux OS is not that very deep. However I use to use the terminal for updates (pamac and pacman), and also installed some software from pacman. As you see I am learning :smile: super + s cause nothing, super + x cause the logout menu to drop down from the M at the left corner.

So problem is still not solved. However now I know that this issue belongs to the Openbox DE. However I’ve not giving up yet. Thanks again for attempts to help me :smile: