[TEST NEEDED] Modern Picom config with blur and rounded corners

Please test modern Picom config with some nice effects:

  • rounded corners
  • blurred backgrounds

How to test?

Save it as ~/.config/picom/configs/modern.conf

Then use Settings Menu super + s → Composer… to set it as active.

super + p is key bind to toggle compositor (Picom)

Let me know if it works for you, please :slight_smile:

If rounded corners works?
If blur effect works? Conkies and terminator.
How about CPU usage?
Blur effect also works for menu, you may need to lower opacity for that - using Colorizer.


blur works
rounded corners works
cpu on btop =4% on top=14% :face_with_raised_eyebrow:


I envy u with your cpu 4%- top 14% but anyway cheers … Lager rules it !

1 Like

Blur and rounded corners working!

1 Like

Works for me too. Round corners and blur, no extra cpu use.


1 Like

It also worked for me.
First, the whole are (except tint2 panel) went blurred (not bad). Then, it went to normal.
Round corners (slightly). Xorg takes between 0.4 and 0.5 % of cpu.
Cannot see the difference with the first modifications to picom settings you did on Jan 5th.

1 Like

I also tried it, the rounded corner is nice. The CPU usage has not changed compared to the previous picom setting.


I changed settings for cavastransparent script and tint2 (this one was hard to spot anyway).

It is spectacular, I would like to put glitter on the sides, it would look great so far i have only achieved this

1 Like

And with weary eyes, harder! hahaha
Thanks for all this GREAT distro :dancer: :tada:

1 Like

It’s a picom shadow question. I found that the default settings makes a vertical shadow
line on the left side of the screen.
If shadow = false it is OK.
Changing shadow-offset-x also has effect.
This screen shows how it looks with the default picom.conf

1 Like

I never seen such effect, very strange… and also “mini screenshot” from screenshot tool looks weird :thinking:

I don’t have a solution, mainly a question.

Is the vertical line there even when all windows are closed?

With me, such a line was the shadow of my xfce4 panel. I then excluded this one from the shadow.

PS :: Try also to toggle conky. Close Tint2 panel. Everything whats possible. See if you can find the source of the shadow.

1 Like

A suggestion : Try

use-damage = false

Thank you guys and sorry for this silly question.
It turned out that plank caused this line. It was hidden.
Moved to the right and carried the shadow there. Then I could not reach by mouse, so uninstalled.
Forget it. Have a nice evening.


Good catch :slight_smile:
I can confirm it is plank.
Easy to exclude… just add this line to section shadow-exclude = [

    "name = 'plank'",

Gist updated, thanks :slight_smile:

1 Like

Exclude works. Although I got used to this in rc.xml

  <keybind key="W-d">
      <action name="Execute">
        <command>rofi -show drun</command>

Neither shadows nor blur works with this compositor for me.

Does it matter if I’m in a live usb?

All right. It works after installing video-linux package, and login again. But not with tint2.