Sudo + pcmanfm

Hi I tried to open pcmanfm from Terminator with sudo because it prevents me from doing certain tasks if I don’t do it as sudo,

It opens the file manager but shows these messages and I don’t know what they refer to. Is this normal, or what is the reason?

That happens when I do the same. I dont know if it is normal but I have never had any issues when doing so. Also, I dont know what those warnings mean and really never worried about them. Maybe I should? Naw, I think we are okay with them.


Pcmanfm has the “Open Folder as Root” action in the context menu (right click menu).


Hi, @napcok
I didn’t know the option, looking at your screenshot, I realised that I don’t get the text, just a lock icon.
Thank you very much.

I dont get that option in my right click list. These are the options I get.

1 Like

This action come from mabox-pcmanfm-actions package. Check if you have this package installed - should be there by default.

1 Like

Oooops, my bad. I was on another Arch based distro at the time. It does not have that package but my Mabox does have it. All is good!


I have the mabox-pcmanfm-actions package installed and also can’t see the Open Folder as Root option. In order to be sure, I uninstalled the package, reinstalled and rebooted the computer.

No cigar.

1 Like

@M0nst3r, Are you sure you use pcmanfm? What is your locale?

@Claudio Can you translate “Open Folder as root” to Spanish?
Then I will include translation.

1 Like

Say no more:


I, by the way, love PCManFM. :sunglasses:

Open Folder as root into Spanish could be: Abrir Carpeta como root.

The reasoning is that we understand root as the account and not the word (raíz) itself. That would sound weird as we use raíz when referring to the starting point of a folder or filesystem. :thinking:

1 Like

Hi, @napcok the translation of open folder as root is precisely “abrir carpeta como root” (root could be understood as sudo or administrator) in the Linux context. As I learned it.
I hope I have been useful to you

Hi, @M0nst3r On my PCManFM it doesn’t say open folder as root; when I right click, this symbol like a padlock appears, when I click it it allows me to open folders as root. It asks me for the password and that’s it, I didn’t realise until I tried to open it with sudo from terminal, it gave me an error and when I saw @napcok’s answer I checked where the option was. I hope it helps you.

So, the mysterious, lonely padlock was the Action all along. :rofl:

I tried and it works. Also with @napcok’s update of mabox-pcmanfm-actions a couple of days ago the text is now showing. :+1:

1 Like

Hi @M0nst3r Well, I’m glad to know that the issue was solved, in my PCManFM the text still doesn’t appear, it does appear if I select an editable file, then a new padlock appears with the text edit as root.