Speaker icon [SOLVED]

Hi,
The speaker icon has the muted (x) symbol always on, left click does nothing at all but actually sound is fine. The right speaker icon does work with left click (mute/unmute) and mouse wheel (volume up/down). How can i fix it?!
2022-03-21_19-28

1 Like

Hi,
can you paste here output of command:

grep -A 12 'volumettf' ~/.config/tint2/nordic.tint2rc
2 Likes
execp_command = ~/.config/tint2/scripts/volumettf
execp_interval = 1
execp_has_icon = 0
execp_cache_icon = 0
execp_continuous = 0
execp_markup = 1
execp_monitor = all
execp_tooltip = L: Mute/unmute, MW: Volume, R: Radio Menu
execp_lclick_command = pactl set-sink-mute 0 toggle
execp_rclick_command = mb-music ipc
execp_mclick_command = 
execp_uwheel_command = amixer -q set Master 2%+ unmute
execp_dwheel_command = amixer -q set Master 5%- unmute

1 Like

Everything looks good here.
So you can try those commands from terminal and eventually replace them to something that works for you.
Try:

amixer

this command should give you some more information.

Alternatively you can also remove this executor from tint2 as you already use some other program to manage volume.
This is probably executor3 from nordic theme so will be easy to find and remove it from tint2 configurator GUI.
Main Menu → Mabox Config ->Tint2 panel → Configure GUI …

1 Like


Is it ok?! I mean the comamnd for the LeftClick.

1 Like

Have you got two output devices?

I have similar issue while connecting to bluetooth speaker.

1 Like

No, only the speakers, connected to motherboard’s line out. But in Volume Control settings i got this from my Dell display “HDMI/DisplayPort (plugged in)” although nothing is there

1 Like

Yeahh, you were right, i disable the “HDMI/Display port” in VolControl configuration and now everything works fine!
Thanks!

1 Like