[SOLVED] Speaker icon non functioning

I can change the volume all I want but this does not change. Any suggestions? Using a Lenovo chromebook 3, 11.6in.

Did you check the volume in the systray.
In this picture the sound is off. But i can slide the volume in the sound settings.



EDIT : i am sorry, i use xfce4-panel. Not a good example for your tint2 volume. :expressionless:

1 Like

The volume in the try works and changes with buttons. But the icon does not. Thanks though.

1 Like

I don’t understand what your question is about… panel icon or Pavucontrol (Volume control window)?

Actions binded by default to “volume icon” in the panel, are:
Left click = mute/unmute
MouseWhellUp/Down = raise/lower volume

Pavucontrol gives you many more choices—depending on the hardware you use.

1 Like

the icon stays at 76 whether i use the mouse or not.perhaps because i customized my volume controls?
this menu is all that happens on a right click.

I actually had the same issue so you’re not the only one, but then I found another program that showed a (even nicer) icon so I did not investigate further. But now I can’t remember how I activated this other icon so I include a screenshot here. I’ll look into this a bit more actually.
EDIT: Ha! the program is just called “Volume Icon”, you can activate it by opening the menu and start typing “volume”. Hope this helps.

1 Like

This 100 percent works. Thank you!

I’m using a crappy Chromebook (made EXTREMELY BETTER by this distro!) I wouldn’t be surprised if some cheap hardware was interfering with usability.

1 Like

Probably you put volumeicon & in your .config/openbox/autostart. Thats a good place for it :slight_smile:

It actually came back by itself after reboot :thinking:

okay my newest problem is i don’t remember how to mark this post as solved. :joy:

At the right side of the title you’ll see a pen(cil). Click on it and insert [SOLVED] at the beginning.

![IMG_0418|231x500](upload://cRMzUdpIxk23O1ftGQFRxUD1Ev5.jpeg) I wish I could tell you it was there but I do not see it. :man_shrugging:

thank you for marking this solved. i was 100% unable to edit the post. :+1:

i have rebooted this machine so many times and it has never been functional.

Volume Icon - Mabox Linux Manual :slight_smile:


ah yes! I forgot I did that!

I know this is solved, but I might have figured out why the original icon is not functioning properly for us in the first place. The tint2 execp_command is

execp_command = ~/.config/tint2/scripts/volumettf

and this script checks if the volume is muted using pactl and an if statement to check if Muted = “no”.
On my machine pactl list sinks | awk '/Mute/ { print $2 }' actually returns no no no no and that is not equal to “no” ofcourse.
I might try to find a proper fix for this if I have time, but I’m quite content with my current solution.

1 Like

I had the same problem.
Go into [Super] + [v] audio settings and turn off everything in the Output tab except the source you want to hear sound from.
It worked for me.