[SOLVED] I can't set the keyboard layouts of my choice

Hi, I really loved Mabox and I am willing to turn it as my daily driver (currently Linux Mint 20 user)

I am trying to set my keyboard layouts as us & gr, however settings are not persistent across reboots and always goes to us, pl & es (us, polish and spanish)

So far I 've tried:

  1. Typing this command but its not persistent obviously either:
    setxkbmap -model pc104 -layout "us,gr" -option grp:alt_shift_toggle

  2. Edited manually the file 00-keyboard.conf in the directory /etc/X11/xorg.conf.d/ with the following contents:

# Written by systemd-localed(8), read by systemd-localed and Xorg. It's
# probably wise not to edit this file manually. Use localectl(1) to
# instruct systemd-localed to update it.
    Section "InputClass"
    Identifier "system-keyboard"
    MatchIsKeyboard "on"
    Option "XkbLayout" "us,gr"
    Option "XkbModel" "pc104"
    Option "XkbVariant" "grp:alt_shift_toggle"
  1. Typed this command but the output is the exact same as above:
    sudo localectl --no-convert set-x11-keymap us,gr pc104 grp:alt_shift_toggle

  2. I used Manjaro Settings manager, but can’t set more than one keyboard layout

  3. Pasted the command in point #1 into .bashrc, no effect here

  4. Tried it to have it in openbox’s own config files, once again no effect

Hi @Twilight0, and welcome to the forum :slight_smile:

Can you try this?

Wow, thank you, that was it, I 've thought it was just an indicator and didn’t have it’s own configuration. I fixed it. I am going to mark the thread as solved.

1 Like

how is possible to set Greek layout , thank you for your help …(i am NEW user …!!!) how … Copy desktop file to needed location: "cp /usr/share/applications/gxkb.desktop ~/.config/autostart/ " ???

Hello @ioannis and welcome to the forum :slight_smile:

You just need to edit the configuration file:

geany ~/.config/gxkb/gxkb.cfg

and replace some language code with gr.

Then restart session.


1 Like

works…thank you !!!

If you don’t need layout indicator running in system tray all the time (gxkb)…
Just add a line to ~/.config/openbox/autostart

setxkbmap -layout "us,gr" -option "grp:alt_shift_toggle" &

And switch between defined layouts by Alt + Shift :wink: