[Solved] Disabling/configuring zswap

EDIT: I might’ve made a mistake in updating the initramfs and grub boot, now it works.

Hello. I’ve recently switched to using Mabox exclusively on my laptop and desktop PC, and it’s extremely smooth, responsive and easy to use. It’s been one of my favorite distros I’ve ever tried.

However, my laptop only has 2GB of RAM, and so it swaps quite heavily. The problem is that it’s CPU is also terrible, and whenever the compression to cache pages is used, CPU usage spikes massively and there’s a freeze until it’s done. This is nearly unusable when using a web browser, and it’d be nice to have a way to disable it. I’ve not succeeded in doing so using the Arch wiki’s instructions, so I suppose the setup is different here.

Thanks in advance.

1 Like