[Solved] Bug for smb shares in bookmarks - left panel?

I added some bookmarks in PCmanFM. These bookmarks refers to my NAS-System. One bookmark is like : smb:// auf

The left panel mirror all the bookmarks of PCmanFM. But all bookmarks of smb shares are not valid.

In left panel the bookmarks to smb shares are cut to “”. I assume that the some character like “:” or “//” are the reason for this mistake. Any idea how to fix that?

1 Like

Hello @bernd
No easy way to fix that currently, as I wrote this to handle local filesystem only.
I will try to look how to handle ssh and smb shares.

Can you please paste example samba line from ~/.config/gtk-3.0/bookmarks?

1 Like

Here are all my bookmarks:

smb:// Download
smb:// home
smb:// books auf
smb:// Pictures
1 Like

Thanks :slight_smile:
It will be probably not possible to make dynamic menu out of samba shares (for browsing directories and files from dynamically generated submenus - as it works for local filesystem).

I’m thinking about just commands to open filemanager at smb (or ssh) locations.

I don’t use samba at all…
Can you try if this command works?

pcmanfm -n smb://
1 Like

This command works fine for me. :+1:

… and sorry for the inconvenience I made…

1 Like

No problem at all :slight_smile:

Thank you for this report.
Such small things are important and it is a chance to make Mabox a little better :wink:

I’ll try to do something about it when I find some free time

1 Like

Please update your system and see if smb shares works from left panel bookmarks.

SSH (sftp) should also work.

1 Like

work perfect :+1: :+1: :+1:

You can mark this topic as solved. :white_check_mark:

Thank you very much for this quick help!