Solve hotkeys defined in RC not working

I ran into the “problem” where from three defined Print key combos only one was working. The funny thing was that A-Print worked but Print and W-Print didn’t.
My first look was at my keyboard layout and fair enough I did choose incorrect on installation but setting this correct didn’t solve my issue. I even reinstalled MaBox with correct keyboard type/layout to be sure but still the problem persisted.
I then used the tool xev (open terminal, start xev and press keys to see info on them) to see if the Print key was recognized and it was (key combo’s are not displayed as one key!).
I did a search on the almighty internet and stumbled on a very old post describing almost the problem I had. One fellow user opted to use scancodes as keynames in the RC file. And although for the original poster it didn’t help I did try it and voila, for me this works fine!.

In xev (mentioned above) also a scan code is revealed (see yellow)


Now you need to convert this decimal code to HEX and add that code to the keybind in the RC file

in this example 107 decimal = 6B hexadecimal. When adding this to the RC you need to add 0x in front of the hexadecimal number. 6B will then be 0x6B, that’s the code you can use instead of the well known name like “Print”.