Run mabox from usb ventoy : mouse appeared but screen black

GoodDay Mabox Team,
My encounters trials mabox on a Ventoy usb
1)Test run mabox mabox-linux-21.11-Herbolth-211120-linux510.iso on usb Ventoy. Was able to boot into gui but black screen and only mouse appeared, no functioning.
2) Press Ctrl + Alt + F2 can go into tty, but key in user: manjaro , password: manjaro
cannot log in.
3)if i depressed Ctrl+Alt+ Backspace error , screen switching seen but turn Red and only mouse appeared, no functioning.
4) had tried to restart and select either free firmware or non-free drivers also result in above 1 and 2 not functioning.
5) Working on Void linux distro, issued
$ inxi -Fxz shows:
Device-1: Intel 82G33/G31 Express Integrated Graphics
vendor: Elite Systems driver: i915 v: kernel bus-ID: 00:02.0
Display: x11 server: X.Org 1.20.13 driver: loaded: intel
unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel G33 v: 1.4 Mesa 21.2.6 direct render: Yes
Dear Devs, any clue how to get this working?
Appreciate kind leads !

Hi @newmant1
user: mabox
password: mabox

hi napcok,
appreciates your kind inputs.

  1. I could login using tty2 with your said username:mabox passwd:mabox but the tt7 , the gui is stuck with a black screen with only a mouse cursor.
    no matter firmware opensource or non-free firmware chosen during bootup.

  2. on grub menu, I tried depressed button ‘e’ to have nonvea=1 set to 0 and only left intel=1 , radeon=0 , then F10 , boot up arrival of same black screen with only mouse cursor.

  3. on tty7, I tried Ctrl+alt+Backspace, it toggle into a red screen with only mouse cursor, doing again got a black screen with the same mouse cursor only. Nothing else !

last but not least, as i googled for information(how to change video drivers or configuration
and troubleshoot) > cat /var/log/Xorg.0.log showed [ 28:259] (II)LoadModule “intel” Failed as (intel module not exist,0) Instead it LoadModule: 'fbdev" and LoadModule:“vesa”

So i issue $ mhwd --pci -l warning '/var/lib/mhwd/db/pci/graphic_drv/…novalid
video-linux 2018.05.04
video-modesetting 2020.01.13
video-vesa 2017.03.12
From the above it indicate video-intel-driver is missing .
When i try to delete nvidia,nouvea, it also indicated not installed. Hm…this appears to be strange as some advice says delete nvidia package would solve the issue but its missing?

Howcome the iso does not provide a choice for selection which video drivers i could choose showing it’s name? Beg your pordon, i just asking in curious mode not being rude.
Appreciates any kind inputs…!

Hi @newmant1
Mabox is based on Manjaro, and proper driver should be detected automatically by MHWD…
Can you try latest Manjaro ISO? For example XFCE.

I will try to build updated Mabox ISOs this weekend.

Thanks napcok, but I does not want to try the normal weight iso. I only interested in lightweight distro, currently like Antix-21, still playing with it while comes to hear about your mabox and gave a try only to knew it doesn’t work out of the box like Antix did.
Will come back to try once your new build is ready, thank you for the tinkle.
HV a great day!

I just uploaded a new updated ISO images to the server.
Maybe it will work for you …

Thank you for the updates. Will come back when I am done with the other explorations. Let other test the new iso first to get into a screen. Appreciates your kind inputs.

Hi napcok,
didi’nt see any verifying .sig or .asc for the new mabox-linux-21.12-Herbolth-211211-linux54.iso.
Oh, so linux.54 is for older hardware.
dare not use doesn’t comes with signatures files for verification.

Anyway, appreciates your kind leads.
Good day !

There are sha256 sums for new ISOs…
Verify with:

sha256sum *.iso