Once more corrupted NTFS directory since update to 5.15. kernel

so far I had a good experience using Mabox linux, but recently I had to deal with corrupt folders and files missing. I know, NTFS is not recommended, but one year, I never had any issues. And I need to share data with windows.
What I discovered is that the 23.10 update affected the kernel from 5.4.xxx to 5.15.xxx.
Now I see those problems. NTFS-3G is unchanged.
What I also see is, that using Veracrypt, I get ‘broken pipe’ and ‘not enough data read’ errors.
I am not enough specialist to deeper dig into that.
Here is what chkdsk said:
Error Index “$I30” for file “4B0”
Fehler im Index $I30 der Datei 4B0 werden berichtigt.
CHKDSK hat in der Bitmap für den Index “$I30” der Datei “4B0” als zugeordnet gekennzeichneten freien Speicherplatz ermittelt.
Index $I30 in Datei 4B0 wird sortiert.
CHKDSK überprüft nicht indizierte Dateien, um die Verbindung mit dem ursprünglichen Verzeichnis wiederherzustellen.
Verwaiste Datei xyz.mp3 (2A7) wird in Verzeichnisdatei 4B0 wiederhergestellt.

51 nicht indizierte Dateien überprüft.
20 nicht indizierte Dateien im ursprünglichen Verz. wiederhergestellt.
CHKDSK stellt verbleibende nicht indizierte Dateien wieder her.
31 nicht indizierte Dateien wiederhergestellt.

Could it be, that the communication between kernel and NTFS-3G is unstable?
Best Regards, Andreas

Did some more research and found that kernel 5.15 uses its own NTFS driver.
question is now, how did I get updated from 5.4 to 5.15? Is the normal update in Mabox also switches to newer kernel?
I found similar problem reports here:

No, you did it yourself.
This is the user’s decision.
Manjaro/Mabox never changes the kernel series used by itself.

Last time I read in 2022 about NTFS3 (the Paragon’s version included in kernel 5.15+) was still not safe/stable and prone to data corruption. If somehow you are mounting your partitions with this one, my humble advice is to disable it and use the old -more reliable- ntfs-3g. :thinking:

Good thing, Paragon is also in data rescue business ;-).
For me it is still a mystery, why I didn’t had problems. I found NTFS-3G in the list of installed software. Could it be, that NTFS3 was somehow disabled and got enabled during a recent update?
I used this line from other chat to disable:
echo ‘blacklist ntfs3’ | sudo tee /etc/modprobe.d/disable-ntfs3.conf
If I have time, I investigate with some older backup image if I was on NTFS3 and had luck that long time.
Best Regards, Andreas

Indeed, backup image shows no NTFS3:
kernel 5.15.125-1

datacine@datacine-R5600G ~ $ sudo mount
[sudo] Passwort für datacine:

/dev/sda7 on /run/media/datacine/Data_Dg type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)

Related note: I got (accidentally) a corrupted NTFS USB stick yesterday.

Managed to fix it with chkdsk from a Windows machine. Still, I said to my self “how on earth is this possible, being using ntfs-3g for so many years? Unless…” and then it hit me, remembering this thread.

So, I plugged the USB stick again and after a: mount | grep -E 'fuseblk|ntfs', lo and behold, it was mounted with ntfs3 :expressionless:. As I never, ever, touched anything related to that (knowing beforehand that it is not safe), can say that Manjaro/kernel/whoknows is setting ntfs3 as default.

In order to disable it (which I did right away), open your console and throw a:

echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/disable-ntfs3.conf

And restart your computer.