Not all conkys were loaded when Mabox start

Hi guys,

I have a problem with conky. When I start Mabox sometimes not all my conkys are loaded automatically. This happens on a physical hardware and also in a virtual machine. I choose Conky Manager to activate the not loaded conkys again. But this behavior still remains.

Any ideas what I can do to assure, that all my conkys are loaded at any start of Mabox?

1 Like

Hi @bernd ,
May I see the content of your ~/.config/conky/conky-sessionfile ?
Question #2: Does pressing Super+c twice make any difference?

1 Like

Hi @zlow,

sorry for the delay in my answer. I was quite busy. The behavior still remain. Here is the conky-sessionfile:

conky -c '/home/bernd/.config/conky/mabox_tools_mbcolor.conkyrc' & sleep 1s
conky -c '/home/bernd/.config/conky/shortcuts_mbcolor.conkyrc' & sleep 1s
conky -c '/home/bernd/.config/conky/sysinfo_mbcolor.conkyrc' & sleep 1s
conky -c '/home/bernd/.config/conky/tiling_terminal_mbcolor.conkyrc' & sleep 1s

Super+c fix the problem. But this seems to me more as a workaround than a solution.

Best regards Bernd

Hi @bernd,
I do not consider myself savvy at all at this question. Someone suggests:

sleep 5 && conky -c ~/.config/conky/mabox_tools_mbcolor.conkyrc & sleep .5

modification of the first line of conky-sessionfile. Or find a value that suffices
Many regards

1 Like

Hi @bernd
Interesting problem.
This may have to do with the speed of your computer and the order in which the startup scripts are run.
Could you try changing the name of the script that starts the Conky session?

mv ~/.config/autostart/conky-session.desktop ~/.config/autostart/z-conky-session.desktop

Another possible solution might be to change Exec=mb-conky-session --autostart line to something like:

Exec=sh -c "sleep 3s && mb-conky-session --autostart"

Please let me know if any of above hints helps :wink:


Hi @napcok,

I tried both options. The first does not help.
The second seems to be the solution. I started my pc several time and everything is fine. All conkies are loaded. Until now the issue seems to be solved. I’ll wait and take look if this configuration survive the next updates :wink:

1 Like