Multiboot USB [Grub4DOS] - booting process stalls with the "Welcome to GRUB" message

Hello everyone, I’ve been trying to run Mabox from my multiboot (16Gb FAT32) usb stick. It has a few other Linux-based Operating Systems installed atm and I can run them with no problem at any time (those installed at the moment include Slax v11.3, Tails v5.8, Mint LMDE-5 Cinnamon and the latest Porteus KDE, let alone those tested in the past but not in use/erased - MX Linux, Refracta, and a few others, including even android based Remix OS). The usb stick has Grub4DOS installed on both MBR and PBR and I have never experienced any issues with running Linux distros from it. Now - when I try to run Mabox from the same usb stick - the grub loader shows Mabox in the list of systems available for boot, but when I select it and hit enter - I end up with a “Welcome to GRUB” message in the top left corner of my screen and inability to run any commands or quit. Not sure if the issue is related to grub4dos settings or to Mabox in particular. Does anyone have a clue how to get the grub4dos loader to boot Mabox or maybe get Mabox “more willing” to be bootable by grub4dos? I’m not a Linux kicking monster pro, no previous experience with Arch based systems (yet), so pls be patient :slight_smile: Thanks in advance for any help!

Update: I’ve tried to test Mabox on that muliboot usb with Qemu right now and the boot process got past the “welcome to grub!” message, finally ending with what you can see on the second screenshot below:

I know that Qemu results are often inaccurate, but that “no suitable kernels available” (kind of) surprises me. I’ve tried to boot Mabox both with the latest kernel 515 and with kernel 54 - all in vain. I’m digging in the net to see if I find a solution to this issue, judging by what I’ve seen so far this is an issue mostly with Arch based distros (at least in relation to Grub2, Grub4dos not mentioned as an issue though) …

Never heard about Grub4dos - what’s the point to use it?
Can’t you just boot normal way?

Found it on sourceforge - seems like old project. Last update decade ago - 2013-04-16

Yes, Grub4Dos is an old project, but it rocks when it comes to creating multiboot pendrives. If you have questions why it’s still in use - some info on that page might give you the answer - Gub4Dos Guide
Yes - I can boot in a normal way, burning Mabox ISO to a usb drive with Rufus or Balena Etcher (or any other similar program), no issues with that. What I want is to get Mabox running on my multiboot usb stick (to minimize the number of usb drives needed for separate live mediums), I’m just trying to figure out why Debian based distros (e.g. Mint or Tails), Slackware based (Slax and Porteus) and even Android based (Remix OS) - are all bootable from my multiboot usb pendrive, and why Manjaro (i.e. Arch) based Mabox does not boot

Maybe Grub4dos developers know something about that?
More modern similar tool(?) is Ventoy: Ventoy
Might work better in 2023 in such use cases - although I never used it.

I also recommend that you use Ventoy for it is actually developing with updates & fixes and does the same use and multiboot safety you have enjoyed with Grub4Dos. I have been using Ventoy for 3 years you can install it from any Manjaro official or Spin distribution for an empty usb drive and run differetn Linux ISOs . You can even create a Live USB Persistent portable OS with Ventoy.

I did try Ventoy in the past - for some reason the multiboot usb drive created by Ventoy didn’t work on my system. No clues why. I also tried AIOBoot a few months ago - and ended up with some distros bootable and some not. I have a simple MBR/legacy setup, dual boot on my main hard drive, so no UEFI/EFI issues. My laptop is rather outdated though not totally crap yet with Intel Corei7-2630QM, 6M Cache, up to 2.90 GHz. The multiboot usb drive I’m using now was created with WinSetupFromUSB and it looked like it could boot any type of OS until I stumbled upon Mabox. I’ve just thought of trying another Arch based distro and see if there’s a similar problem again or not.
Update: I’m downloading the latest Manjaro KDE ISO from the official web page to give it a try tonight and see how that goes. Will update later on the results, meantime thank you guys for getting back to me

Hi @Magnetic,

I did a test with ventoy MBR and Mabox.
It did’t work the first time i made the usb. So i tried it a second time.
I tested it on a dell precision m4700, 4 core (2012). It boots the live session for installation.

Though i installed Mabox with ventoy UEFI on a medion (Intel(R) Pentium(R) 3558U @ 1.70GHz, 1684 MHz), 2 core. (2014)

I guess you had bad luck in the past with ventoy. Maybe first format the usb, to be sure its clean. And use ventoy after that.

:bird: Good luck.

1 Like

I downloaded the latest Manjaro KDE ISO and tried to give it a go last night. Ended up with the same “Welcome to Grub” message on the screen, so there’s obviously smth that obviously needs a tweak to make Grub4Dos and Manjaro (and Manjaro based distros) “friendly” to ensure successful booting.
So far I’ve found some hints related to Grub2, but I’m sure there’s smth alike in case with Grub4Dos (where tweaking the “grldr” and “menu.lst” files might be even easier).

Related to Grub2: if you want to boot a “stubborn” image and Internet isn’t helpful, the only one way is to dive deeper into the image itself and figure it out.

isoscan/filename - we need the path for image boot menu.
linux … - unique additional boot parameters.

So we have to mount that particular iso image to check the configuration we need for a successful boot:

$ sudo mount -o loop /path/to/iso /mnt/




are two popular locations to check boot configuration. We need some info like

label live
menu label Try *distro name* without installing
kernel /casper/vmlinuz.efi
append file=/cdrom/preseed/*distro name*.seed boot=casper
initrd=/casper/initrd.lz quiet splash

The “kernel” parameter contains the Linux option for the “linux (loop)…”, the same with “initrd” path. “append file” should be added to “linux (loop)…” line.

Some Linux distributions use a parameter “isolabel”, it can be obtained from “isoinfo” command output:

isoinfo -d -i image.iso

I will try to dig deeper when I have free time, compairing a Debian or a Slackware ISO vs an Arch ISO, running the commands above may give a clue :grinning:

Re: Ventoy - I will try to give Ventoy another go, I guess there’s no unique “all-purpose” software at the moment that could give 100% support to all kinds of ISOs existing there.

A small update: last night I added Endeavour OS ISO to all others on the same multi-boot usb stick, and it launched without any problems. Just like Manjaro, Endeavour OS is based on Arch. That leads to the conclusion that Arch itself is out of “business” and the problem apparently concerns Manjaro and some (or one would suspect all) distros based on it. Perhaps when creating their off. ISOs Manjaro developers use some specific software, but this is still more of a guess … ???
I haven’t really dug how this tool works, and I may be wrong - but maybe it’s likely that software released 14 years ago can’t cope with a file system that debuted much later :thinking:
Latest realease of Grub4DOS tool is dated at 2009-03-31.

Hi @napcok ,

Thank you for attention you are paying, sometimes devs just ignore similar “tiny” problems, though they are not that “tiny” for the end users. Grub4Dos is still maintained by Chenall on Github as far as I know, and no matter how outdated Grub4Dos might be - it does boot the latest Arch based Endeavour OS (Cassini v22-12). That article in Wikipedia mentions Slackware as using OverlayFS - I doubt it’s the cause of boot failure, because I have the Slackware based Porteus (latest off. ISO) on my multiboot stick right now alongside other systems - and it does boot nicely without any problems. I don’t expect anyone here to find an immediate solution hence Mabox is actually a fork of Manjaro. Guess possibly Manjaro developers might have a clue, I wouldn’t be surprised if the problem is caused by some tiny code issue in the config files, alas I’m just far from being a Linux guru…

If the tool is maintained, it is best to ask an expert, i.e. the maintainer.
For me, it’s a completely exotic tool - designed for an equally exotic for me - operating system :wink:

I wouldn’t call a tool capable of booting most ISOs there - Debian, Slackware, Android and even Arch (except Manjaro and Manjaro based distros) - an exotic one… Anyway, I’ve pointed out a problem here, I’ve dropped a couple of lines on a Manjaro forum too, and I will try to get in touch with the Grub4Dos maintainer as well, if I find a solution I will post it here. Meantime - thank you guys for getting back to me and best of luck to Mabox!
P.S.: if you compare a multiboot usb stick with Grub4Dos installed on it with a similar usb drive prepared with Ventoy or Eay2Boot (prior to writing any ISOs on them) - you will see the difference in free space left. Less space occupied by code in case with Grub4Dos is the proof of better efficiency. (IMHO)