Manjaro dropped ZFS

Manjaro dropped ZFS support


Tried to install the new updates this morning and got the following when I ran pacman -Syu:

maboxlinux is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing zfs-utils (2.2.0-2) breaks dependency 'zfs-utils=2.1.13' required by linux61-zfs

I followed the link in your article, which is how I found out Manjaro dropped ZFS support.

Running yay will allow me to do a partial upgrade, but I’m concerned about how to deal with my ZFS pool.
Any idea on how I can resolve this? Any help would be appreciated.


I don’t use ZFS, but it looks like you can use zfs-dkms for now.

ZFS extramodules; i.e., linuxXX-zfs, have been dropped from the repos. There have been recent difficulties building them and no one on the Manjaro Team uses ZFS.
Please install zfs-dkms instead. You will to need to manually remove the old 2.1.13 extramodule package(s) first to install the new 2.2.0 packages; i.e., with linux61:

sudo pacman -R linux61-zfs && sudo pacman -Syu zfs-dkms

Thanks for the reply. I lied yay didn’t let me do a partial upgrade either it just through the error farther down.

The article didn’t instill a lot of confidence that zfs-dkms while be around for long either.

Just a FYI, everything works after the upgrade

Thanks again