Mabox on Macbook Air 2014

Just installed Mabox on an old Mac Book Air form 2014. The whole installation took 4:35 min! Boot time 17 sec. Form my point of view amazing for such an old hardware. But there was one challenge. After the installation WiFi does not work. A driver was missing. My problem was, I had not possibility to connect may old Mac book to Ethernet because I did not have the necessary adapter.

But I had an idea. I enabled Bluetooth and connected via Bluetooth my Samsung mobile phone. With this Bluetooth connection it was possible to establish a internet connection via Bluetooth tethering. With this connection it was possible to download the BCM4360 driver.

After downloading this driver the Mac book work perfectly with Mabox Linux. I don’t know if it is possible. But from my point of view this necessary driver should be available by default.

1 Like

Well…should be available?.. nope not in my opinion. Yes its a bummer but it’s already a long time these old drivers have not been all available.
I have a 27" iMac from 2009. Mabox works fine on that but I need to manually install the Broadcomm driver.

If I read the above correctly there a a few versions of the Broadcomm card that need additional drivers while others are supported out of the box.
This doesn’t help you but it’s just how it is. Same with Windows that also doesn’t have the drivers aboard for ALL hardware (admitting they have a lot, contributing to the ever growing size of the install).
It’s all about preparing for instalation and now you know for future installations what could be needed.

3 Likes

It is supported and available.

I also have a BCM4360 in my imac late 2015 (also on a late 2013) and I don’t use broadcom drivers at all since theese chips has been supported by the kernel for a long time.

The reason it doesnt work is can be a tainted kernel due to a conflict between the wl driver and the open source brcmfmac driver.

dmesg from my system before removing wl driver.

12.490257] wl: loading out-of-tree module taints kernel.
[ 12.490265] wl: module license ‘MIXED/Proprietary’ taints kernel.
[ 12.490267] Disabling lock debugging due to kernel taint
[ 12.492598] wl: module verification failed: signature and/or required key missing - tainting kernel
[ 12.543617] wl driver 6.30.223.271 (r587334) failed with code 1

lspci -k on my system

Network controller: Broadcom Inc. and subsidiaries BCM43602 802.11ac Wireless LAN SoC (rev 01)
Subsystem: Apple Inc. BCM43602 802.11ac Wireless LAN SoC
Kernel modules: brcmfmac wl

As you can see I have both wl and opensource driver brcmfmac wich is not ok to load at the same time.

On Arch based systems i always uninstall any wl drivers

On Arch I do sudo pacman -r broadcom-wl-dkms

Then sudo modprobe brcmfmac and wifi is working.
After removing broadcom drivers

Network controller: Broadcom Inc. and subsidiaries BCM43602 802.11ac Wireless LAN SoC (rev 01)
Subsystem: Apple Inc. BCM43602 802.11ac Wireless LAN SoC
Kernel driver in use: brcmfmac
Kernel modules: brcmfmac

You can test this from a live usb if you want and see if it works on the Air. No need to reboot the live system. If it works then it works instantly.

On Debian 12 for instance wifi is working out of the box on this system. Probably other distro’s also.

3 Likes

Thank you very much for this useful information. :+1:

On additional question. Currently I’m struggle to get the facetime camera at my MacBook Air to run. Can you use the webcam at your mac? I tried to install the following driver but It failed.

My camera is working fine . No problem.

What is the output of inxi -Gaz and lsusb?

you dont need facetimhd driver for that model. This driver you need: uvcvideo

Then install cheese (gtk) or kamoso (kde) to test or just do this in terminal if you have vlc installed

vlc v4l2:///dev/video0

1 Like

It seems to me, that my technical know-how is not good enough to install this driver. :woozy_face:
I took a look at this website, but I was not able to install this driver.
Here is my inxi -Gaz - log:

Graphics:
Device-1: Intel Haswell-ULT Integrated Graphics vendor: Apple driver: i915
v: kernel ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
bus-ID: 00:02.0 chip-ID: 8086:0a26 class-ID: 0300
Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: modesetting
unloaded: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1440x900 s-dpi: 96 s-size: 381x238mm (15.0x9.4")
s-diag: 449mm (17.7")
Monitor-1: eDP-1 model: Apple Color LCD built: 2012 res: 1440x900 hz: 60
dpi: 126 gamma: 1.2 size: 290x180mm (11.4x7.1") diag: 341mm (13.4")
ratio: 16:10 or 15/9 modes: 1440x900
OpenGL: renderer: Mesa Intel HD Graphics 5000 (HSW GT3)
v: 4.6 Mesa 23.0.4-0ubuntu1~22.04.1 direct render: Yes

This here is a printout of my current Linux mint installation. I messed up my Mabox installation and now I’m trying to understand the driver problem with another distribution. I don´t know if that help.

Hopefully you have an idea how to run my factime.

facetimehd drivers are for macs that are older then yours…

No camera there…And it should work without any problem on mint as Device-2. Did you try to install other drivers on that system?
Try theese commands in terminal to see what you get

less /proc/modules| grep uvc
and modinfo uvcvideo
v4l2-ctl --list-devices

Did you try ?

sudo modprobe uvcvideo and then run the vlc command

If not post dmesg, lspci -k, lsusb and inxi -Faz
Does it work on live system? mint, eos, mabox?

That is what I got:

less /proc/modules| grep uvc
uvcvideo 110592 0 - Live 0x0000000000000000
videobuf2_vmalloc 20480 1 uvcvideo, Live 0x0000000000000000
videobuf2_v4l2 32768 1 uvcvideo, Live 0x0000000000000000
videobuf2_common 77824 4 uvcvideo,videobuf2_vmalloc,videobuf2_memops,videobuf2_v4l2, Live 0x0000000000000000
videodev 258048 3 uvcvideo,videobuf2_v4l2,videobuf2_common, Live 0x0000000000000000
mc 65536 4 uvcvideo,videobuf2_v4l2,videobuf2_common,videodev, Live 0x0000000000000000

modinfo uvcvideo
filename: /lib/modules/5.15.0-78-generic/kernel/drivers/media/usb/uvc/uvcvideo.ko
version: 1.1.1
license: GPL
description: USB Video Class driver
author: Laurent Pinchart laurent.pinchart@ideasonboard.com
srcversion: 94B26031176226E31EE24B5
alias: usb:vpddcdscdpic0Eisc01ip01in*
alias: usb:vpddcdscdpic0Eisc01ip00in*
alias: usb:v8086p0B03ddcdscdpic0Eisc01ip00in*
alias: usb:v29FEp4D53ddcdscdpic0Eisc01ip00in*
alias: usb:v2833p0211ddcdscdpicFFisc01ip00in*
alias: usb:v2833p0201ddcdscdpic0Eisc01ip00in*
alias: usb:v1C4Fp3000ddcdscdpic0Eisc01ip00in*
alias: usb:v1BCFp0B40ddcdscdpic0Eisc01ip00in*
alias: usb:v1B3Fp2002ddcdscdpic0Eisc01ip00in*
alias: usb:v1B3Bp2951ddcdscdpic0Eisc01ip00in*
alias: usb:v19ABp1000d00dcdscdpic0Eisc01ip00in*
alias: usb:v19ABp1000d01[0-1]dcdscdpic0Eisc01ip00in*
alias: usb:v19ABp1000d012[0-6]dcdscdpic0Eisc01ip00in
alias: usb:v199Ep8102ddcdscdpicFFisc01ip00in*
alias: usb:v18ECp3290ddcdscdpic0Eisc01ip00in*
alias: usb:v18ECp3288ddcdscdpic0Eisc01ip00in*
alias: usb:v18ECp3188ddcdscdpic0Eisc01ip00in*
alias: usb:v18CDpCAFEddcdscdpic0Eisc01ip00in*
alias: usb:v1871p0516ddcdscdpicFFisc01ip00in*
alias: usb:v1871p0306ddcdscdpic0Eisc01ip00in*
alias: usb:v17EFp480Bddcdscdpic0Eisc01ip00in*
alias: usb:v17DCp0202ddcdscdpic0Eisc01ip00in*
alias: usb:v174Fp8A34ddcdscdpic0Eisc01ip00in*
alias: usb:v174Fp8A33ddcdscdpic0Eisc01ip00in*
alias: usb:v174Fp8A31ddcdscdpic0Eisc01ip00in*
alias: usb:v174Fp8A12ddcdscdpic0Eisc01ip00in*
alias: usb:v174Fp5931ddcdscdpic0Eisc01ip00in*
alias: usb:v174Fp5212ddcdscdpic0Eisc01ip00in*
alias: usb:v152Dp0310ddcdscdpic0Eisc01ip00in*
alias: usb:v13D3p5103ddcdscdpic0Eisc01ip00in*
alias: usb:v0E8Dp0004ddcdscdpic0Eisc01ip00in*
alias: usb:v0BD3p0555ddcdscdpic0Eisc01ip00in*
alias: usb:v0AC8p3420ddcdscdpic0Eisc01ip00in*
alias: usb:v0AC8p3410ddcdscdpic0Eisc01ip00in*
alias: usb:v0AC8p332Dddcdscdpic0Eisc01ip00in*
alias: usb:v06F8p300Cddcdscdpic0Eisc01ip00in*
alias: usb:v05E3p0505ddcdscdpic0Eisc01ip00in*
alias: usb:v05C8p0403ddcdscdpic0Eisc01ip00in*
alias: usb:v05ACp8600ddcdscdpic0Eisc01ip00in*
alias: usb:v05ACp8501ddcdscdpic0Eisc01ip00in*
alias: usb:v05A9p7670ddcdscdpic0Eisc01ip00in*
alias: usb:v05A9p264Addcdscdpic0Eisc01ip00in*
alias: usb:v05A9p2643ddcdscdpic0Eisc01ip00in*
alias: usb:v05A9p2641ddcdscdpic0Eisc01ip00in*
alias: usb:v05A9p2640ddcdscdpic0Eisc01ip00in*
alias: usb:v058Fp3820ddcdscdpic0Eisc01ip00in*
alias: usb:v04F2pB071ddcdscdpic0Eisc01ip00in*
alias: usb:v046Dp082Dddcdscdpic0Eisc01ip00in*
alias: usb:v046Dp08C7ddcdscdpicFFisc01ip00in*
alias: usb:v046Dp08C6ddcdscdpicFFisc01ip00in*
alias: usb:v046Dp08C5ddcdscdpicFFisc01ip00in*
alias: usb:v046Dp08C3ddcdscdpicFFisc01ip00in*
alias: usb:v046Dp08C2ddcdscdpicFFisc01ip00in*
alias: usb:v046Dp08C1ddcdscdpicFFisc01ip00in*
alias: usb:v045Ep0723ddcdscdpic0Eisc01ip00in*
alias: usb:v045Ep0721ddcdscdpic0Eisc01ip00in*
alias: usb:v045Ep00F8ddcdscdpic0Eisc01ip00in*
alias: usb:v0458p706Eddcdscdpic0Eisc01ip00in*
alias: usb:v0416pA91Addcdscdpic0Eisc01ip00in*
depends: videobuf2-v4l2,videodev,videobuf2-common,videobuf2-vmalloc,mc
retpoline: Y
intree: Y
name: uvcvideo
vermagic: 5.15.0-78-generic SMP mod_unload modversions
sig_id: PKCS#7
signer: Build time autogenerated kernel key
sig_key: 75:7A:05:56:12:13:0C:E4:F2:F6:B1:90:9C:50:42:33:83:2E:68:ED
sig_hashalgo: sha512
signature: 31:58:31:5D:9B:3A:83:2F:18:A3:5A:99:9F:1D:AD:3D:1C:28:66:B5:
1F:65:D7:6E:F6:79:DA:A3:75:AD:44:8D:68:82:D8:A7:12:70:86:CA:
91:EE:60:A2:07:AF:F0:AD:55:1D:20:14:11:2C:8B:B0:02:CD:80:8C:
C2:32:17:FC:0C:0F:17:F3:8F:66:0A:CE:9A:82:03:18:73:03:AD:45:
39:60:F6:2B:2E:3E:A1:6D:33:0F:14:74:A0:A5:BA:6C:73:A7:BE:B9:
61:17:C3:B4:C3:E4:05:12:A4:A5:FC:EA:DF:66:0B:35:79:44:BB:30:
4B:5E:75:39:2E:D8:C5:FA:EC:4C:47:03:4D:A0:C8:05:A6:86:1E:76:
1A:A6:29:B0:69:9B:BC:F5:E3:82:61:31:D5:D0:BA:6E:40:83:30:5F:
57:6B:20:BD:22:6F:39:69:20:65:E6:B5:71:A0:FD:8E:6E:81:D0:B8:
0B:CD:DE:A8:A9:1D:3F:AB:87:9F:46:67:2E:E5:04:F1:3C:12:74:B0:
88:E3:0E:70:AD:8D:D4:D0:B1:D1:90:F7:B6:9A:66:B5:1E:18:D4:22:
2B:ED:40:EC:98:9D:89:2B:F4:29:C0:90:2F:FE:DE:0A:33:6F:92:B5:
A4:0F:DC:5A:E8:A2:95:5E:A2:B1:1A:24:19:37:58:3C:A1:93:4C:36:
3C:54:EE:F4:F6:BB:A2:EB:00:AE:8E:73:11:31:9A:F8:BC:28:28:11:
2E:22:E2:B5:56:3A:E1:1B:FF:F6:8E:52:9D:2A:F3:55:47:FF:4D:17:
EA:F5:40:AC:0B:A5:27:F1:8B:F2:60:4E:0B:D5:20:9E:12:47:B7:F1:
B7:0B:15:11:60:86:79:D7:62:BD:45:0F:CD:0A:DE:50:C2:85:B8:FE:
F6:D6:5C:88:08:13:98:20:4F:A9:DE:D4:12:EE:AD:F8:F0:56:93:FA:
B8:20:AB:FA:49:7A:8D:56:C0:EF:88:FE:FD:22:F0:B1:18:2A:4A:FE:
70:50:73:BE:77:F3:1D:FB:94:6D:D2:E7:C6:E1:39:47:10:A1:35:F4:
4B:74:11:CE:B2:DD:3E:66:D0:60:C0:A7:24:AF:7C:85:F1:F2:BB:22:
C1:E0:BC:46:24:C0:04:57:F9:A0:DA:41:E9:26:75:00:0D:44:BB:AC:
14:B1:ED:61:CE:08:CE:C3:53:17:20:FB:1C:FA:B6:A0:9D:B4:64:40:
38:19:ED:68:53:F8:02:D9:DA:9A:EF:2F:63:7D:2A:2B:E8:7E:D2:69:
DE:D3:07:5E:B1:4E:6C:48:01:C6:D5:46:05:1A:5A:0E:61:6B:FB:07:
9A:EB:76:04:7D:EC:DD:31:49:B3:4C:EA
parm: clock:Video buffers timestamp clock
parm: hwtimestamps:Use hardware timestamps (uint)
parm: nodrop:Don’t drop incomplete frames (uint)
parm: quirks:Forced device quirks (uint)
parm: trace:Trace level bitmask (uint)
parm: timeout:Streaming control requests timeout (uint)

v4l2-ctl --list-devices
Cannot open device /dev/video0, exiting.

Thank you for your support. I really appreciate it.

Seems to me that the drivers are there… You run kernel 5.15? There was alot of problems with uvcvideo on 5 series kernels. Try to run a more current kernel from 6.1 to 6.4. Run a live system if you will for instance mabox or Endeavouros wich have 6.1 and 6.3 . Atm im running Endeavouros and mabox with kernel 6.4 on both my imac’s . I have no issues except a bluetooth problem on the imac that dualboot 2 linux systems. The other one no issues at all.

What does lsusb show?

If your camera is listed in lsusb then try the belov commands

And then:

Thank you for your helpful information. After testing a few distros with Ventoy I saw, that lsub does not show any information about a installed camera. With this in mind, I wanted to install the old MacOS on my Mac Book again. The idea was to see if the facetime camera is working on the original OS.

What a nightmare. The Apple support was not able to help me to reinstall the old OS again, because I erased the whole disk for Linux. They were not able to tell me how make a bootable usb stick under Linux or under Windows. After wasting one hour at the Apple hotline a friend of mine gave me a helpful hint. So I’m currently reinstalling MacOS to see if the camera is still working.

This experience shows me how good it is to be part of the Linux community. Normally you find here solutions even with very exotic problems. I will remove the MacOS as soon as possible, when I got the information about the camera. After this I will reinstall Mabox again.

Try booting it up holding Option+Command+r . It should boot in online recovery mode installing the highest version of macos that it supports

1 Like

They don’t want to do anything without you paying for help on this old hardware.

Here from Apple support:

Start up your Intel-based Mac in macOS Recovery

  1. Restart your Mac.
  2. Immediately press and hold one of the following key combinations until you see the startup screen:
  • Command-R: Start up from the built-in macOS Recovery System. Use this key combination to reinstall the latest macOS that was installed on your system, or to use the other apps in macOS Recovery.

Theese 2 options will probably work for you.

  • Option-Command-R: Start up from macOS Recovery over the internet. Use this key combination to reinstall macOS and upgrade to the latest version of macOS that’s compatible with your Mac.

  • Option-Shift-Command-R: Start up from macOS Recovery over the internet. Use this key combination to reinstall the version of macOS that came with your Mac or the closest version that’s still available.

  1. If you see a lock, enter the password for your Mac.
  2. If you have multiple volumes on your disk, select the volume you want to recover, then click Next.
  3. If requested, choose an administrator account, click Next, enter the password for the account, then click Continue.When the Recovery app appears in the menu bar, you can choose any of the available options in the window or the menu bar.
1 Like

Thank you very much. It is such a shame for the Apple support. From my point of view it was a lack of knowledge. Even in this linux forum I have got the right solution. I tried the camara it work under MaverikOS fine. I will try to find another solution. It seems to me that is a more difficult problem. None of the Linux Distros I tried got the camera working.

I found this for ubuntu, maybe it’s also (a bit) applicable for Arch based distro’s?

Also this one, even more promising. Arch Wiki link with a lot of info!

https://wiki.archlinux.org/title/Mac/Troubleshooting

1 Like

If you still have macos running you should take out the info you need from this macbook with all the drivers running before going to linux again.

Go to mac info and find the camera and get the info there. There are also ways to extract the correct drivers from a mac to use in linux. Don’t know since I never needed to do that.

1 Like

Thank you for this information. I think I will leave it as it is. I wasted so much time in that issue. It will be much more easier to use a external usb camera. It was from a technical point of view interesting to get this peace of hardware running. But I have to realize that my technical know how is not good enough to solve that issue.

Hi Guys,

I would like to share my wired experiences in the Mac Universe.

After accepting, that the facetime camera will never work I decided to change the internal SSD of my MacbookAir. The 128 GB original SSD should be replaced by an 512 GB SSD which was described as “compatible” with my MacBookAir.

After replacing the internal SSD with the new one. I realized, that the new SSD was not found by my MacBookAir. Ok, I booted Mabox from a usb-stick. The new SDD was found by Mabox and I started to install Mabox on my new SSD. After rebooting - the same result. No SDD found.

I reinstalled Mavericks on a USB-Stick and even the MacOS does not find the SDD. After some research I found out that some firmware updates were needed to identify this new SSD. But it was impossible to install these updates. Because my MacOS was too old and there was no way to update to a newer OS-Version.

Luckily I found a patch to install a new Version of the MACOS at my old MacBook. After several updates my Macbook was patched with the newest firmware … and the new SSD was found by my Macbook.

Now I was able to reinstall Mabox on a big and very fast SSD.

These journey took me one week and hours of researching. I hope this was my last journey through the wired Mac universe.

Now arrived in Maxbox.

3 Likes