Mabox Not booting after installing another distro

Hi. I installed mabox Linux and everything is fine but when I install another Linux distro mabox just now when it boots is stuck on logo on manufacturer. I have tried reinstalling and updating grub to no avail. Any ideas? Ty

1 Like

Hello, May I ask a few questions to understand the problem better.

  • Have you updated Mabox after first setup?
  • Did you install any drivers via “Manjaro Settings”
  • What is other OS exactly?
  • On what partition you installed Mabox’s and other OS’s /boot/efi?
  • Did you format boot/efi partition during installation of second OS?
  • Can you load bios on your machine and what are the options?

Hi ty.

  • I didn’t update the system. Fresh install

  • I didn’t install any drivers (manjaro)

  • 2nd round of installing different OS’s but it broke after I installed archcraft and I believe its doing this after installing an arch based system. I have peppermint also installed.

  • mabox is on sda3 while the others are on 2 and 4. The efi is on sdc1

  • no never reformatted efi. Also have windows on SDB all by itself.

  • BIOS loads as usual.


Welcome @Th3Bird you are right about your 3rd point… Archcraft or the last distro you installed might have overwritten ( and deleted) your efiboot folders the same does win10/11 does if you reinstall them in efiboot partition.
In the case of mabox ( Manjaro stable based) you could try doing chroot with the same Mabox live usb to restore partitions and boot but as you have a distro salad kindda I am not sure if this could work out fine a 100% to have all your distros booting in the updated grub. Hope this can help somehow.


hi ty. Yea, what happens is that it is stuck on the post boot logo. I understand your responce and Im going to take a screen shot of when I boot directly from boot menu, not grub. I get some LightDM errors. Ill send in a few. ty

Did you try to restart d-bus service from a terminal or tty with command : systemctl start dbus.service

I couldn’t really get to a prompt. I tried init=/bin/bash and something else. What I did do is reformat that partition and reinstalled so I didn’t get any lesson on that one. Ty though I would go in and restart its .service right?

  1. Seems like this problem is not related to Mabox at all.
  2. You installed another distribution, and GRUB bootloader comes from this newly installed distribution.
  3. Seems like this new distribution failed to detect Mabox as instelled previously and did not add it to GRUB correctly - this is the reason why Mabox not boot correctly anymore.

Proposed solution:
Search Internet for something like:
Dualboot GRUB (name of your newly installed distribution)

Ask you newly installed distribution community about dualboot, and how to configure it properly.

Maybe also worth to look at:
GRUB at Archwiki

OK great. Ty and I’ll look the info up. Ty