Mabox Live USB 22.08 hangs at "Reached Target Graphical Interface"

Tried booting both versions of the ISO-image on my desktop PC. When running the the 515 version ISO and choosing proprietary drivers it hangs at “Reached Target Graphical Interface” during the boot process. If I run open source drivers then the graphics goes haywire with strange colors, fragments and screen tearing. If I try the 54 version it just hangs “Reached Target Graphical Interface” regardless which drivers I choose.

I get the feeling this is related to the graphics hardware as I have no issue booting or installing the Live USB on laptop. The desktop which I have issues with runs a AMD Ryzen 9 5950X with a NVIDIA GeForce RTX 3080.

Any advice or workaround for this issue are appreciated.

RappScallion try disabling the compositing in the live environment before you start the install keybindings = (supper+p)

I have the same (or similar) problem on a desktop system with Ryzen 5 5600G. The live stick only boots until Reached target Graphical Interface. How can I ‘disable the compositing’?


2301 version solved this problem. Now I can boot also on the Ryzen 5 5600G. Great!!

It did not work for me, still have the same issue hoping mabox can address this problem soon.

No need to necrobump old topics -as you already wrote in another.