Mabox do not lock the screen after suspend

My dconf looks fine, all the locks enabled.
I can lock using Super + L, but not after suspend.

Tried with i3lock and with betterlockscreen (and its systemd service), but no luck.

I wonder if this issue is related.

1 Like

For those having the same problem, you can do this workaround:

Right click on the power button to edit the exit.csv file

On the Suspend line, it must say
Suspend,mbscreenlocker && systemctl suspend,system-supend

Save the file, and on the Preferences menu, select Reconfigure Openbox.
Now suspending through the menu button should lock the screen.

This workaround will not lock the screen if you use the physical button.

2 Likes