Kernel 5.15 issues

I thought I would try the latest kernel 5.15 and installed it through manjaro settings manager.
I had several sudden and unexpected crashes ( after a couple of hours use). It seems this is not an isolated case and saw a post on the Manjaro forum which seemed to confirm this.

I reverted to 5.14 and all is fine :+1:. I will wait for developments.

Ref: I run Intel Core i5 with integrated graphics so no Nvidia problems are involved

5.15 is important as it is/will be new LTS (Long Term Support) release with planned end of life in October 2023.
Next Mabox ISO update will be released with 5.4 kernel and probably with 5.15 (instead of 5.10).
Currently we have versions:
5.15.2 in Stable branch
5.15.5 in Testing
5.15.6 in Unstable


I realise thee importance of 5.15 which is why I tested it but, unfortunately for me, I (and others apparently) had some problems which will hopefully disappear as the kernel matures.

I see that lists kernel 5.15.6 as the latest release so perhaps some of those glitches that I experienced with 15.5.2 have been addressed. :pleading_face:


It seems to be that latest kernel is sending out acpi firmware interrupts calls (aka kworker messages) they are visualized in the sysconkyrc in the cpu display. Maybe this is only affecting low to some demanding graphic uses and only to Intel acpi mabox users with Intel so far. Acpi modules manage the use of power and in my case I detected this a week ago when keyboard led light started turning on by its own, thought about the latest stable update then and paid attention to new elements displayed by sysconky. I investigated that one can check this kworker new situation from terminal (grep . -r /sys/firmware/acpi/interrupts/) paying attention to those high values which are different from 0. And found some extra info about this situation (which also surprised Linus T some time ago) and how this could have its origin and how it could be solved partially…but its origin deals with the management of power in your system (AC/DC power, monitor battery power, monitor parts, cards or motherboard modules)… and this needs to be checked if this same situation affects other user within this past week. I leave some pics. Please check and comment if this is happening to you.


To find how many acpi modules are managing services in your system you can check as (ls -l /usr/lib/modules/$(uname -r)/kernel/drivers/acpi) :


The same here


Please try from terminal this command: grep . -r /sys/firmware/acpi/interrupts/
This will show a long output which will show those high values different to zero, they indicate the issues with acpi manager in one’s system.


There are three with values ​​higher than 0

/sys/firmware/acpi/interrupts/gpe66: 5 EN enabled unmasked
/sys/firmware/acpi/interrupts/sci: 5
/sys/firmware/acpi/interrupts/gpe_all: 5