HP Probook 450 g5 frozen when browsing www

Hello,

After a fresh install Mabox linux strarts and works fine, but when I start a web browser and try to open a page the system hangs up and frozing. I cant do anything but turn it off.

Fresh install - without swap. On win10 or 11 works fine. The problem the same with or without updating my system, and the same with FF and Chrom.

I have done a bios system check and everything is fine.

There seems to be a lot of reports about this model on the web…

A google search will prove that :wink:

This may be a problem due to not having a swap partition:

It could also be a video driver problem
Have a look at this:

1 Like

So - thank you for your help. You can find problems almost every rigs on the web…

  1. I tried it with swap - the problem remains,
  2. My secure boot is disabled.
  3. I dont think its a video driver problem, cos the left of the apps, celluloid works fine.

First boot after install. I turn on the comp. Log in, open FF. Try to open any web site, and its frozen in 20 second. Its the same with Chrome, but now its fresh install with swap.

ps: I have two comps and on this was Win10 for 5 years - without any problem and frozen problems. Really. I prefer Linux, and this is a lighter comp than the other - and I would like to live on one machine. But it wont work… :frowning:

Are you using wayland?
Try to change to Xorg
Or vice versa

Also try this:

I use X11 - checked from terminal
I cant find how to change - on the login screen there is only Openbox possibilities. Inside Mabox I cant find out how to change, but it installed, I have checked.

I prefer FF - and C is not installed on the system now. Its clean install (yet).

Ok, you are on X, no wayland, my bad, we are on openbox :smiling_face:

Firefox has this setting, try to turn it off

Turned it off and worked about 1 minute - I was able to open 2-3 pages. I was about on Mabox Forum page to write You, its working - when frozened. :confused:

Try to get the last logs

sudo journalctl -p 3 -x -S -2h > boot.log

This one write errors for the last 2 hours to boot.log

Post the result at https://pastebin.com/ and post the link here

Nothing. Just prompt back.

But… I think You were right about video driver. I opened the Control center and System/HW and installed installed video-linux open source driver and since then I can use FF.

I turned back FF settings to default and its working. I will try… and write back.

1 Like

Nope - its still frozing. Today I am fedup. I cant believe it… I will sleep and will decide what to do…

Thank you for your efforts.

1 Like

Weird :thinking:

Let’s gather a little bit more info:

  1. Install btop with: sudo pacman -S btop
  2. Open btop in the terminal and then Firefox in the same screen side by side.
  3. Browse normally for a while until freezing happens.
  4. Take a picture of the screen (with your phone if the laptop is locked).
  5. Share with us the btop part please.

Dear M0nst3r,

Thank you for your help. Yesterday, I was fed up and disappointed (another problem on a problematic week) - and put an Win on the HP. Working - but much slower, than MaBox. :frowning: I tried to find the solution on the net, tried different methods, apps. There is no log(s), cos frozen immediately and there is only one way - turn it off. :frowning:

On Monday I will ask for an other SSD and change for discovering this problem. I have installed many systems MS and Linux distros as well, but never seen this kind of problem. Now, I don’t have a glue what the problem is. :frowning:

As soon as I got the other SSD I will write.

Thank you very much.

Dear M0nst3r,

Picture of the crash. Its the Live media. I havent installed onto the system. Here I put some memory to the HP and put the Video memory to 512Mb. Nothing changed. I made 3 attempts. The first and the second frozing was so fast that I was not able to pull FF to the right side with keyboard combination. In this case there was no internet connection. At third time I connected to the net and takes couple of minutes to the crash.

Thank you.

I have a bad feeling about your laptop. :thinking:

  1. You are booting from an USB and still freezes.
  2. This bit right there: “frozing was so fast that I was not able to pull FF
  3. The fact of how stable and resilient the Linux kernel is.

The 3 main culprits (in order) could be: memory, motherboard and CPU.
So, boot once more from USB please, select the Memtest option and let it run until it finish at least one cycle and tell us about the results.

There is a mem test in the BIOS menu. I have already done it.

On the live iso I havent found any memtest option - or screwed up something. What do you think?

Beside this the mem test was successful in the BIOS.

I think its worth to try with another distro aswell…

  • “There is a mem test in the BIOS menu. I have already done it”

    From personal experience as a technician, I would recommend you not trusting the memory test from UEFI, specially from a brand like HP. :face_with_hand_over_mouth:

  • “On the live iso I havent found any memtest option”

    You got a point; is indeed missing (at least when you boot in UEFI mode). There is already an EFI Memtest but only our good @napcok can include it in Mabox’s ISO. In the meantime you can try creating a bootable USB with MX Linux ISO, which already includes that Memtest.

    As people say, is better to be safe than sorry, and no matter what distro you choose, discard beforehand any problem you may have with your computer. :wink:

I made an Live Mx Linux ISO pen. I have tested my mem. No errors.

After this I run Mx live distro and test it with the same way. Its frozing. I think you are right. Huston we have a problem. :confused: I have installed word, acrobat, I watched film on Win - withou any problem. Copified 100gb… without any problem.

My only idea is the BIOS (which is the newes) but secure boot is off and there is no other important thing which Linux kernel crashed this way.

My problem is solved as far as I know now. Stay on my old asus x550vx. I dont want Win (which is work perfectly on Hp), but on my old Asus Mabox boots and runs much faster. I can do my job on Linux with wps and quoppa.

Finally, thank you for your kind help.

Best regards :slight_smile:

j