How do I reverse scroll touchpad [SOLVED]

I want to reverse the scroll of the 2 finger touchpad. Does anyone know the file to edit and line?

I ended up editing /usr/share/X11/xorg.conf.d/40-libinput.conf

Added the 2 lines below after Driver “libinput” in the “touchpad” section, then rebooted

Option “NaturalScrolling” “on”
Option “ScrollMethod” “two-finger”

Not sure if a reboot is needed but my system reboots fast enough.

1 Like

Hello there, you are almost there with your first line, just the second brackets need a different input:
Option “NaturalScrolling” “True”

And for your second option Two-finger Scrolling method (provided it is not wworking for you) you might need to install extra package from AUR :

1 Like

Thanks. I meant to say I had figured it out. “on” and works but changed it to “true” and it worked as well. The two-finger worked for me as well with out needing anything from aur. Ty for your help.

I’m so new to Linux.

2 Likes

Hello, I just installed Mabox and tried this then reboot. I couldn’t boot anymore.
I reinstalled Mabox and tried again : same thing. What do you think is the problem ?

1 Like

Finally I answer to myself. It works fine if I modify /etc/X11/xorg.conf.d/50-touchpad.conf.
I still don’t know why the system is blocked at startup if I edit /usr/share/X11/xorg.conf.d/40-libinput.conf.

3 Likes

Just in case you need some help, I leave you my personal file added to my everyday drive, Mabox.
Hope it helps. When you mean Reverse method for libinput driver points to Natural method, so you have to replace before the last line as follows: Option “NaturalScrolling” for ScrollMethod edge conflicts with the reverse “NaturalScrolling” option

Source: libinput(4) — Arch manual pages

3 Likes

Thank you very much. It works fine now.

3 Likes

Well… I thought it was ok but I did the same operation on another laptop, and I was blocked at boot on the prompt just before the grub screen : pc logo, prompt, black screen, prompt, and blocked. It seems there is a conflict with something else. GUI setting for this would be great.

2 Likes

Did you check a mispelling line or the correct name of this file in folder rootfile system>etc>x11>xorg.conf.d>50-touchpad.conf ? You can check it using a mabox or any manjaro ISO usb drive and penetrate your local drive rootfilesystem and if there is no mispelling you can even remove that file and reboot to see if your frozen system restarts ok again.

3 Likes

Indeed it was certainly a syntax error because I did it again on two laptops and it worked. So I’m happy ! Thanks for your help.

3 Likes