Failed to start mabox in hp mini

Well, continuing with the theme
Something happened and I can’t fix it.
When I start the hp mini, I get a file error vmlinuz… and it doesn’t load the grub.
It gives me the different kernel options available, but none of them work.
I go to the advanced functions and I can’t get past that.
I connect the Pendrive with the Live for the installation and it goes to Failed to start lightdm…, it does a whole process and stays there, I press ctrl +alt+F2 to try to enter and it does not allow me to do it, it does not recognize the user or the password so I can not move forward.
Any suggestion that can help me to solve it?
Thank you very much.

That sounds like an incomplete/interrupted update. :thinking:

If this was the case, create a bootable USB with the latest Mabox ISO and try to chroot the HP Mini in order to complete the update. Don’t forget to verify your / free space beforehand.

Another, most drastic approach, could be a full reinstall of Mabox but only if you have a separate /home partition.

1 Like

Hi @M0nst3r .
You may be right, I am not the user of that machine, I just rescued it for a friend’s wife.
According to what she told me she turned it off and when she turned it back on she could not log in but she has no idea what could have happened, I was researching and there are many reasons which makes it very difficult to find a concrete answer, I only saw that it happens with laptops so as I have no experience with laptops I am testing.
I tried to chroot from the usb I have with the installation iso but it does not accept the user and the password, the iso I used was the same one I used to install Mabox on that netbook, maybe it is no longer useful, I will download the new one to see if I can fix it.
Thank you very much for your help.

Translated with (free version)

Too bad. The full reinstall seems even better now but first a few notes:

  • That HP Mini, very likely, has a HDD and because of age could be failing. This could be another cause of the sudden failure.

    • Boot again with the USB and latest ISO, connect to Internet and issue: sudo pacman -S gsmartcontrol.
    • Open that App and share with us the first and second tabs (General, Attributes).
  • If the disk is failing, a SSD is due and, in fact, make that laptop a lot faster and long lasting.

  • The kernel 6.1 is good but “old”; the current 6.6 LTS is even better with support for more devices.

  • If the owner really interrupted the updates by accident, instruct her to do it with the GUI (pamac) once in a month or something. And of course, that she must wait for it to complete before turning off the computer.

1 Like

Well, I already have the new ISO loaded on the USB, as soon as I get some time I’m going to try your instructions if I manage to do it, it depends on the machine to support the whole process, which I had not achieved with the previous ISO.
They are not going to put an SSD, it is not worth the investment, the disk is good, I checked it from the BIOS with the application that brings for that purpose.
As for the hp updates, I took the trouble to teach him how to do them, and due to the frequency and size of some of them, I recommended him to do them periodically and never interrupt the process, I guess if that was the problem it was not caused on purpose.
In the meantime I’m going to read about that gsmartcontrol to be aware when using it. If I succeed, I’ll post the results as you ask.
As for the 6.1 kernel on my pc I didn’t decide, I let the machine use the one that suits it, so far, every kernel change has been with the updates and I have the updates up to date. It is a subject that I don’t dare to touch due to lack of knowledge.

To my great surprise I saw that the new Mabox ISO includes gsmartcontrol so I didn’t have to download it. These screenshots show the information you asked me to share.
Things turned out as follows, when I was trying to install Mabox I reached a point of no return and I couldn’t move forward, since I had antix on the same

pendrive, I thought about installing it to delete the old Mabox, delete it with antix and reinstall Mabox, no I don’t know how or why, antix was installed but it modified something on the pendrive so I couldn’t use it again, when I tried to boot from the live usb a message appeared about grub, to use the tab key for options but I couldn’t get past that Since I didn’t know if the error was on the HP mini or on the pendrive, I tried it on the desktop machine I’m using, exactly the same thing happened, so I decided to format it and load everything again.
Now I’m going to try again and then I’ll tell you how it turned out, if it was solved or not.

1 Like

I’m truly impressed. That Hitachi HDD was manufactured in 2011 aprox. and still shows no signs of damage.

1 Like

Hi, @M0nst3r.
The disk of that hp has almost no use, the machine is impeccable but if that caught your attention, pay attention to this other one, it is my main disk, the one that has Mabox working in my machine, a friend picked it up from the trash and gave it to me, with that disk and other machines that were going to be scrapped I built the PC that I usually use and with other leftovers I built the other one I have in case it fails. This PC is from 2009, the HDD may be older, I have nothing to reproach it, I recognize that it is a little slow but it does its job quite well.
Having managed to assemble the PCs without investing more than in the batteries for the Bios was a great achievement for me that I lack knowledge of electronics and also marked my entry into Linux. Since then I have not returned to visit a technician except in the case of notebook that is also rescued and to change the battery you have to disassemble the whole thing, as I have no knowledge or proper tools I have taken it to change the battery and since then I suppose that if it runs out I will see the technician again to change it, it is a Dell Vostro, if I remember correctly from 2007. It works perfect, it belonged to another friend who was going to throw it away because it was no longer useful with windows, as he knew that I walk with Linux he gave it to me to see if I could make it work, and there it is working perfectly.