Epson v19 scanner setup

When I use Debian, Ubuntu, opensuse or puppy Linux I have no issues setting up and using my Epson v19 scanner. Why is it so difficult in Arch to get my scanner working. I checked the AUR and it looks like what is supposed to work has been deprecated. Why can’t my scanner just be plug and play? The deb and rpm files are available on the Epson support site.

I love mabox but if I have spend a lot of time researching how to get my scanner up and running, it’s not worth it.

Please let me know how I can resolve my issue so I can continue to enjoy mabox.

Thanks so much!! :grinning:

1 Like

Hello there, I recalled a similar situation last year with a Perfection V19 scanner and found it in the Manjaro Forum. Maybe you already tried this but anyhow I leave this link for you. (I guess you firstly installed manjaro-printer packages :sudo pacman manjaro-printer )
Good luck.


At first I was unable to use any arch distro because I couldn’t get my Epson v19 scanner to work. There is a driver in the AUR that contains the number 650. This worked for me! I’m happy to report that my brother printer/scanner, Epson v19 scanner and cannon lide 300 scanner all work fine now after installing the respective drivers.


Quite glad to hear you solved your printers issues. Best wishes & stay safe. Please state or mark your issue post as solved.

1 Like