Dell Latitude 3540 suspend broke wifi? [Solved]

This Dell laptop has already been reloaded once. Two other computers have had nowhere near as much trouble as this laptop. Beginning to think it has something to do with suspend.

Anyways, the latest issue is, opened lid, used the web, things seemed to be fine. Installed some updates, then rebooted. During reboot, fsck found three pages of file issues but still booted the machine. In terminal, tried to do a pamac update but the database was corrupt. Rebuilt pamac and pacman databases, no new updates. Web browser says there is no internet connection. Hmm, strange. Plug laptop into Ethernet, works fine. Try to use WiFi - nope.

Right-clicking network, it is enabled. Editing connections, there is an Ethernet - Wired connection 1 and a Wi-Fi - My Wi-Fi entry. Looking into both, everything looks normal. But when I unplug the Ethernet cable, the networking icon changes from a RJ-45 icon into an “up-down-arrow” icon (not a radio signal icon.) There is a blue function key for enabling WiFi, it does nothing (perhaps not recognized.)

So WiFi refuses to start or otherwise work. Can anyone suggest any troubleshooting tips? Thank you.

  1. Assumed a necessary file was truncated accidentally. But checking /lost+found, it is totally empty.

  2. sudo lspci -vnn shows the Ethernet and WiFi details as follows (while connected to Ethernet):
    01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.
    RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
    Subsystem: Dell Device [1028:0608]
    Flags: bus master, fast devsel, latency 0, IRQ 18
    I/O ports at 3000 [size=256]
    Memory at e0600000 (64-bit, non-prefetchable) [size=4K]
    Memory at e0400000 (64-bit, prefetchable) [size=16K]
    Capabilities: [40] Power Management version 3
    Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Endpoint, IntMsgNum 1
    Capabilities: [b0] MSI-X: Enable+ Count=4 Masked-
    Capabilities: [d0] Vital Product Data
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Virtual Channel
    Capabilities: [160] Device Serial Number (hidden)
    Capabilities: [170] Latency Tolerance Reporting
    Kernel driver in use: r8168
    Kernel modules: r8169, r8168

    02:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 Wireless
    Network Adapter [168c:0036] (rev 01)
    Subsystem: Dell Device [1028:020c]
    Flags: bus master, fast devsel, latency 0, IRQ 19
    Memory at e0500000 (64-bit, non-prefetchable) [size=512K]
    Expansion ROM at e0580000 [disabled] [size=64K]
    Capabilities: [40] Power Management version 2
    Capabilities: [50] MSI: Enable- Count=1/4 Maskable+ 64bit+
    Capabilities: [70] Express Endpoint, IntMsgNum 0
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [140] Virtual Channel
    Capabilities: [160] Device Serial Number 00-00-00-00-00-00-00-00
    Kernel driver in use: ath9k
    Kernel modules: ath9k

  3. After booting, disconnecting Ethernet, and failure to start WiFi, sudo dmesg tails with this:
    [ 29.988695] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [ 29.988699] Bluetooth: BNEP filters: protocol multicast
    [ 29.988703] Bluetooth: BNEP socket layer initialized
    [ 30.120020] Bluetooth: MGMT ver 1.22
    [ 30.158987] NET: Registered PF_ALG protocol family
    [ 31.272811] enp1s0: 0xffffb911000cd000, 34:17:eb:64:06:54, IRQ 46
    [ 35.422159] r8168: enp1s0: link up
    [ 268.603805] systemd-journald[274]: /var/log/journal/3d7829f3426342d3aa94697383460326/user-1000.journal: Journal file uses a different sequence number ID, rotating.
    [ 298.732626] Bluetooth: RFCOMM TTY layer initialized
    [ 298.732638] Bluetooth: RFCOMM socket layer initialized
    [ 298.732646] Bluetooth: RFCOMM ver 1.11
    [ 1560.268770] python[31307]: segfault at 0 ip 00007592f86d7144 sp 00007fff0c55c118 error 4 in _testcapi.so[7592f86d6000+7000] likely on CPU 2 (core 1, socket 0)
    [ 1560.268786] Code: 74 0c 48 83 00 01 c3 0f 1f 80 00 00 00 00 48 8b 05 99 71 00 00 48 83 00 01 c3 66 66 2e 0f 1f 84 00 00 00 00 00 90 f3 0f 1e fa <8b> 04 25 00 00 00 00 0f 0b 0f 1f 00 f3 0f 1e fa 48 83 ec 08 48 8d
    [ 2226.518591] r8168: enp1s0: link down

  4. Bluetooth is supposed to be disabled. I don’t use it, nor want it enabled. rfkill list reports:
    me@lat3450 ~ $ rfkill list
    1: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: dell-bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: no
    3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    4: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

  5. sudo iwconfig reports:
    lo no wireless extensions.

    enp1s0 no wireless extensions.

    wlp2s0 IEEE 802.11 ESSID:off/any
    Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
    Retry short limit:7 RTS thr:off Fragment thr:off
    Encryption key:off
    Power Management:off

  6. sudo ip link set wlp2s0 up works, and iwlist wlp2s0 scan | less shows my (and my neighbor’s) WiFis.

  7. Tried installing netctl and running wifi-menu, which found my WiFi - added password and… nothing.

It’s like Arch just forgot how to switch to WiFi or enable it. Any ideas?

Got it. After the latest big update, things started working again. Unsure how much affect either of the following had on it, but this was needed:

  1. /etc/modprobe.d/r8169_blacklist.conf was renamed to /etc/modprobe.d/r8169_blacklist.conf.DISABLED. Unsure how or why this got here (probably an update), but seems to work fine with it disabled.
  2. When rebooted, rfkill showed like above, except that dell-wifi was Hard blocked: yes. Pressed the blue WiFi function key, the WiFi light turned on, and it connected like normal.