Can't Update from Pamac

Using Pamac, I get this when I attempt to update:

could not satisfy dependencies:
- removing wxgtk-common breaks dependency 'wxgtk-common' required by wxgtk2

What do I need to do in order to update?


It is good habit to search forum before posting.

Apparently, that

yay -R wxgtk2 modulo

Did the trick.

(The upgrade is now underway).

1 Like

Except for this problem with python-dephell-setuptools:

E       TypeError: ConfigOptionsHandler.__init__() missing 2 required positional arguments: 'ignore_option_errors' and 'ensure_discovered'

dephell_setuptools/ TypeError
short test summary info 
FAILED tests/ - TypeError: ConfigOptionsHandler.__init__...
========================= 1 failed, 4 passed in 0.68s ==========================
==> ERROR: A failure occurred in check().

Is there a fix for that?

Do I need python-dephell-setuptools?


This package comes from AUR.
Have you rebuilt the package?

The first thing to do if a package coming from AUR does not work after an upgrade is to rebuild it.

If it still doesn’t work after rebuilding, you can ask the maintainer on the AUR website.


Thanks for the info.

The main problem was solved.

I’m not sure why the only one the wouldn’t update is installed.

I always remove the AUR apps from the upgrades until the rest of the upgrades are done. All the apps (including several from AUR) were upgraded except this python one.

Thats simple.
If package have no newer version it is not upgraded.

It may break because of upgraded dependencies - so manual rebuild/reinstall is needed.

There IS an upgrade.

It won’t rebuild due to an error:

So as I already wrote… ask maintainer of that package :slight_smile:

Also no need to paste the same error code again and again. Go to AUR page and pass it to package author/maintainer.