Cannot share files via USB with my phone

When I plug a phone into USB Mabox throws Error The name :1.61 was not provided by any .service files. This seems to happen with any phone.

I found a workaround: I just installed the Nemo file manager and it works fine now.

It’ been a while and probably it works fine for you now, with nemo.

I had the similar issue with an android phone (thunar / pcmanfm) .
Installing the following helped me.

$ yay android-file-transfer-linux-git

It will appear in the jgmenu. [Android File Transfer]
You need to connect device first to use the application.
After that internal and external data are accessible with pcmanfm or …


1 Like

Had similar issue (update of libmtp at 26.1.2023, as it worked earlier), and also nemo worked, but android-file-transfer-linux-git could not find any MPT device.

On libmtp - Browse /libmtp at there is a version 1.1.20, but latest version points to 1.1.19 for some reason.

Sorry, I don’t understand what you try to explain, about 1.1.20 points to 1.1.19. :hibiscus:

I must say it does feel like a work around.

My experience and actions.
  • The following is installed on Kernel 6.2.
android-file-transfer 4.2-3
gvfs-mtp 1.50.3-1
jmtpfs 0.5-3
libmtp 1.1.20-1
mtpfs 1.1-4
What do I do to connect to my phone : Thunar/PcmanFm
  • After installing Android-File-Transfer, I do a reboot (probably not necessary).

  • Then I connect the phone with the computer. (cable)

  • Check the phone by taking it off the screenlock.

  • Close popups from the file manager. (automount)

  • Start Android file transfer. A window appears.

  • It sees my device, but not right yet.

  • Then I click Kill Users. And accept the following warning window.
    Then the correct device appears. In my case a Motorola with /e/os.

  • There is now possibility to continue with this application as a tool. I CLOSE THIS WINDOW.

  • After closing Android file transfer, the storage media of the phone appear in Thunar.

After I did everything above 1 time and then reboot, the file managers (Pcmanfm and Thunar) see the motorola, and I don’t need to start Android-File-transfer again to make a connection.
That’s what it looks like it for now.

Checked everything with cable plugged in and unplugged during boot.



Is 1.1.19 (green tag) the best version or 1.1.20?
( libmtp and pcmanfm got an update and since then my devices only work with nemo.)

There are several ways to address the issue.

I would recommend consulting the Arch wiki first.

1 of the methods, I describe above.

Personally i would not advice to use Sourcefource to download applications from for your Arch.

ps :: My experience with Android-file-tranfer is, that indeed I had to do the operation once.
From now on, the phone mounts automatically. (Pcmanfm and Thunar).