Broken update

HI there,

While doing update get an error about some invalid or corrupted package.
How to check which one is it?

You can try:

sudo pacman -Syyu --debug