Bluetooth Not detecting any devices

I have a pair of Soundcore Q35s that aren’t detected or even the JBL GO 2 mini speaker. Any pointers on how to resolve this?

FYI: Tested with multiple devices but they don’t show up on the detected list.

1 Like

Hi @Duncan-Ireri ,
What have you done and what not?
Press Super and type autosta then select ‘Choose apps and services’
Tick Blueman Applet
Next time when you log in Blutooth icon must be in your upper Tint2 panel.
Rightclick on Bluetooth icon / select Adapters and set Visibily to Always visible
Then Leftclick and having switched on your JBL and/or Q35 devices click on search
There will be some confirmation prompts.
Mark them with tick as trusted and with the key symbol pair them.
Sorry if this is not a 100% correct description. Play with it, google and be creative.

You are quite right about Bluetooth as enabled is not detecting new devices ( though it is still working with older added devices) some times. In my case this got solved, after turning off my laptop for a while… and then tried one more time and got my Bluetooth card detecting my new device ( also a an external new BT speaker) and pressed this should be as a safe device added. Greetings.

Hi @zolw - big thanks for the follow-up. The issue is even when I click on the applet and run a search, nothing comes up. Rebooting does no favours as well.

Tried the lot, nothing. FYI I use a desktop with a BT adapter which works on both EOS and Arcolinux.

This is minor thing but maybe the speaker’s list is “full” (I remember a similar case of BT speakers refusing to connect because of this).

Try resetting your device and see how it goes. :thinking: