Beta release - Mabox Linux 21.11 Herbolth

If you like to test upcoming Mabox new release and help to make it better try beta :slight_smile:
More info in blog post:

Enjoy :slight_smile:

3 Likes

Just playing with it now…

One thing I notice (and it may not be specific to this beta release) it that it seems every application has its own font setting…

Also, I just installed gimp to edit these screenshots, and I see it does not honor the theme set by the theme manager.

  1. There is no global settings for fonts. GTK Apps, Openbox window decorations, tint2 panel, menu and conky - all have its own configurations. Terminal also.
  2. Some GTK Apps did not reload settings automatically, especially PCManFM - which is started in daemon mode (for automounting). Try restart those apps, use ReloadGTK from Mabox Config menu or logout to have changes applied.

This is not fully integrated Desktop Environment. Just Window Manager with some other pieces mixed together :smiley:
Don’t expect to much :smiley:

1 Like

Yes, I know, don’t take me wrong here…

And I know about pcmanfm and the whole daemon thing too

I was just wondering if there is a way to balance all these font settings in order to have a more consistent result.

For example, look at Manjaro Settings here; I don’t know what it’s based on but this font is huge!

Manjaro Settings Manager is a Qt based app … to complete the mix :slight_smile:

For me it looks acceptable…
Probably it depends on currently used GTK theme :wink:

1 Like

The GIMP uses its own theme by default.
You can change it for system theme in Preferences.

2 Likes

ok, I figured it out

I was using

xrandr -s 1680x1050

to set the resolution (and had all those issues)

The I used arandr to set the resolution
This is the command saved by arandr

xrandr --output Virtual-1 --primary --mode 1680x1050 --pos 0x0 --rotate normal --output Virtual-2 --off --output Virtual-3 --off --output Virtual-4 --off

That fixed everything
Sorry for the noise!

1 Like

@sng If you want the same font everywhere, you need to set it in GTK and QT.
The fastest and best way is to use the Mabox Control Center > Layout/Appearance > QT, GTK and Openbox Settings.

A quick way is also to use for openbox font mb-jgtools places > Menu/Panel settings > Size and fonts.

Sorry for the Polish language in the screenshots, but you should have no problem finding it.

3 Likes

Thanks for the info!

I am ok with the default, the problem was due to my using xset -s instead of arandr output.

1 Like

Beta2 installed and no issues so far. Excellent work.

2 Likes