13th gen Intel CPU + NVidia?

Hello and good day. Built a new PC and was having video trouble in Mabox; just figured out the reason why and will answer this issue below. Figured someone else would have this same issue and could benefit from this info.

First, the hardware: lscpu reports a 32-core i9-13900KF. The KF specifically does not have on-board video. I was hoping this would curtail some of the issues surrounding multiple-video Intel systems, but alas I can’t get the nvidia driver to load. The mainboard (Gigabyte Z790 UD AC) has some nvme drives installed (which gives a warning in the logs but seems to work), and upon initial live boot and install, things work well. Video card is a GM107 (GM117?) GTX 750 Ti. This is using the latest .iso and after update to 6.2rc8 kernel. 6.1 LTS kernel also works. However, these both default to modesetting / linux video.

If an attempt is made to install linux62-nvidia or otherwise follow the advice at NVIDIA - ArchWiki we end up fully booting to the last displayed TTY line, but no GUI. Can then log into the system through Ctrl-Alt-F2 second TTY. That line is:
/dev/nvme0n1p1: clean, 624872/61030400 files, 11635036/244112896 blocks.

At first, it was apparent in /var/log/Xorg.0.log that vesa was not found, and nouveau and modesetting were totally taking over, despite the claims that nouveau would be automatically disabled. Nothing nvidia was listed.

Then the Arch link explains that for Intel systems, it may be necessary to add ibt=off to the kernel parameters in /etc/default/grub and rebuilding grub. This made no difference. Nor did adding noveau.modeset=0. [Side note, it’s easy to tweak/test these by pressing ESC at the Mabox boot logo, selecting advanced config options, and pressing e to edit a boot line, then F10 to run it.]

Okay, so then perhaps mkinitcpio needed to be run to rebuild the kernel images and include the missing drivers. This rebuilt ok once or twice, but also gave some the following:
rmmod: ERROR: could not remove 'nouveau': no such file or directory
modprobe: FATAL: Module nvidia not found in directory /lib/modules/6.2.0-1-MANJARO
It has never tried to use any nvidia driver yet; it always reverts to nouveau or modesetting.

Then I thought of checking mhwd -li from the TTY to list the installed PCI configs, and it now reports that only video-nvidia and video-linux are installed, along with a “Warning: No installed USB configs!” I’m hesitant to try removing video-linux here, as Xorg.0.log successfully loads modesetting, fbdev (then unloads it), even glamoregl (and still loads nouveau), but still fails loading vesa as not found. I’d rather not make the system totally un-bootable if possible - don’t have integrated video to fall back on.

It seems like it’s just not attempting to load / install the nvidia driver. Solution below!

1 Like

The problem was, the linux62-headers and linux61-headers were not installed. That simple! Install those, reboot, and presto… loads the nvidia driver perfectly.

Now on this 13th-gen Intel, it WAS necessary to add ibt=off to the kernel parameters in /etc/default/grub and rebuild grub. The system will not boot without that.


Hello, after upgrading kernels (and video driver, firmware) several times since the previous, I just tried changing ibt=off to ibt=on and the system seems to boot normally now.

So somewhere, the Intel Branch Tracking issue must have been patched. If you have upgraded kernels and drivers, try pressing ESC at boot, press E to edit the boot command, change to ibt=on and press CTRL-X or F10 to attempt booting. If it boots normally, suggest testing the system for awhile to make sure everything still works properly. If you reboot, it must be re-edited. Only after testing do sudo nano /etc/default/grub and sudo grub-mkconfig to make the change permanent.

Generally, IBT is just a safeguard to prevent the CPU from running arbitrary code. So it is a security feature, much like DEP (Data Execution Prevention); good to have it enabled if possible. Enabling it should not affect performance.