Mabox boots into latest installed kernel after upgrade. Is this Manjaro's doing or..?

I cannot find any Mabox-specific packages that would be updating grub to boot into the latest installed kernel after a system update, so I’ve asked the Manjaro folks this as well:

Anyone have any idea why, after a system upgrade and reboot, grub will boot the latest kernel version I have installed, whether or not I was using it before the update? Right now I have 5.4 and 5.10 installed, and I have been running 5.4. After an update/reboot, if I don’t get to the grub menu before it disappears, it will boot into 5.10.

I have looked at the grub pacman hook but cannot find any reason to believe it would be resetting GRUB_DEFAULT, for instance–it just runs update-grub, and /etc/defaults/grub is unchanged (I may get a .pacnew, but my old configs stay put). And I have poked into all the grub dirs I can find under /etc or /usr, but nothing is obviously causing this.

I don’t know grub well enough to know where else to look for the answer. I can live with it: it is not massively annoying to check if I am still running the kernel I was yesterday and to reboot if not.

But it is annoying enough for me to want to change this behavior. Anyone know why/how it happens?

Mabox does not have any specific lowlevel packages of its own like kernel, grub, systemd etc.
Booting works exactly like in Manjaro, that is:

  1. GRUB is hidden - use ESC to get to it
  2. GRUB remembers the last user’s choice
  3. If you installed a newer kernel, it will be started automatically the next time you boot.

So what you need is…

  1. Hit Esc while booting to see GRUB.
  2. Go to Advanced options for Mabox Linux


  1. Select kernel you like to run.
    All subsequent startups will use the kernel you selected



Yes that is what I figured. Just asking here to be thorough.

I have set my grub menu to show at boot because I am dual booting Windoze on this machine–although I have yet to boot back into Windoze since installing Mabox in, what, October of last year? :slight_smile:

Grub remembers my kernel choice until a system upgrade from Manjaro. Hard to reproduce until the next one, but I might try a few things in the meantime.

Thanks for confirming what I thought!

1 Like

Maybe for your situation solution will be pacman hook which will modify GRUB_DEFAULT option to point wished kernel. Alternatively you can use grub-set-default command. Look into Grub documentation to see how these options works :wink: